[Slackbuilds-users] Problem building lilypond

Bob Snyder bob.snyder at cox.net
Sat Dec 10 21:09:56 UTC 2011

On 12/10/2011 09:52 AM, Rob McGee wrote:
> On Saturday 10 December 2011 11:27:35 Bob Snyder wrote:
>> On 12/10/2011 12:51 AM, Eugen Wissner wrote:
>>> 2011/12/10 Bob Snyder<bob.snyder at cox.net
>>>      When building lilypond (with sbopkg) I get the following
>>>      error:
>>>         ERROR: Please install required programs:  mf-nowin mf
>>>         mfw mfont mpost
>>>      I'm guessing that these are all part of metafont and/or
>>>      metapost. I have a complete install of 13.37 and it appears
>>>      that at least metafont is installed (mfw and mpost don't
>>>      answer up to a command line invocation). I have already
>>>      installed the listed dependencies fontforge and mftrace
>>>      Any idea what's going on?
>>> "su -" already tried?
>> Well I'm building as root of course, which is where the problem
>> occurs.
> The point is http://slackbuilds.org/faq/#su ... which is explained
> here: http://slackbuilds.org/howto/#su
> Ensure that you have a clean login environment as root. This also
> applies to a shell from which sbopkg is invoked.

Ah. I had read this several times when I first started using SBo, but 
forgot and fell into a bad habit of using "su -c sbopkg". Sorry for 
being a bonehead. It works now.

Thanks Eugen and Rob,

Bob S.

More information about the SlackBuilds-users mailing list