[Slackbuilds-users] CHECKLIST/office

Karel Venken kava at online.be
Tue Nov 19 18:05:15 UTC 2013

Robby Workman wrote:
> On Mon, 18 Nov 2013 21:05:53 +0100
> Karel Venken <kven at sandbubble.org> wrote:
>> pdfedit does not build on x64
>> gcc complains about
>> /tmp/SBo/pdfedit-0.4.5/src/xpdf/xpdf/Object.h:209:3: error: a storage
>> class on an anonymous aggregate in class scope is not allowed
>>      mutable union {  // value for each type:
>> I manually intervened in the SlackBuild script to be able to remove
>> the 'mutable' from the indicated file Object.h after which the build
>> could be finished. I found the resulting binary in src/gui/pdfedit
>> which can be started. I have never created a Slackbuild or worked
>> with git so I am not sure how to fix the patch to get the proper
>> result. I'll try to figure this out but maybe someone can pick this
>> up.
> Well, does anyone use pdfedit any more??  This is in my pending
> removal branch:
>      office/pdfedit: Removed (build failure)
>      If upstream still hasn't bothered to port this to qt4, then
>      I have to wonder why we're still dragging the corpse along.
>      Signed-off-by: Robby Workman <rworkman at slackbuilds.org>
> -RW
I don't use it myself -just tried to help out, but I am only starting to 
learn slackbuilds ;-)- so for me it is OK to remove it. I am currently 
looking into minidlna but I'll make a separate post for this.


More information about the SlackBuilds-users mailing list