[Slackbuilds-users] Samhain Update

Richard Scott Smith pilbender at gmail.com
Fri Nov 22 23:21:35 UTC 2013

I think you missed the point here.  We want to use generic Bourne Shell 
not Bourne Again Shell.  I was asking whether it was correct, not 
whether it worked on Slackware.  Even though it's for Slackware Builds, 
the script should still be logical and correct.

I guess it's being picky but I like the fact that we try to make our 
stuff the best that it can be.

On 11/22/2013 04:01 PM, 
slackbuilds-OfFMTzho8CfQT0dZR+AlfA at public.gmane.org wrote:
> Sorry for top posting, short comment. On slackware systems,
> #!/bin/bash = #!/bin/sh so it is the same.
> $ls -al /bin/sh
> lrwxrwxrwx 1 root root 4 May 18  2013 /bin/sh -> bash
> $
> On Fri, 22 Nov 2013, Richard Scott Smith wrote:
>> Now I'm confused.  I don't use #!/bin/bash on anything.  I always use
>> #!/bin/sh.  Are you referring to the upstream source?  Or was I
>> inadvertently using bash specific features somewhere in the build script?
>> Backing down the optimization on 64 bit only portion of the build
>> scripts should satisfy the multilib compilation.  Can you send me your
>> changes, a git patch is fine if you don't want upstream changes yet,
>> so I can test on a multilib system?  Or upstream is fine, just let me
>> know which branch to pull from and I'll test it.
>> I know multilib is "not supported", but that's actually how I'm going
>> to use it for most of my systems.
>> If you are in a hurry stop reading :-) A side note follows:
>> My colo provider went out of business a couple of weeks ago.  I was
>> being auto billed, so I didn't know it until my server went offline.
>> No one notified me.  I've been with these guys for 7 years.  So my
>> server that was 64 bit only, not multlib, is in limbo.  I'm waiting
>> for the property management attorney to let me have it back since they
>> seized all the assets of the colocation provider.
>> My other systems rely on multilib because of skype and other 32 bit
>> only software.  I'm a consultant and I work with a lot of overseas
>> groups, so I end up having to use this stuff.  In addition, the kernel
>> from Slackware 14.1 does not boot in the latest version of Virtualbox,
>> it actually does work with the 14.0's 3.2.29 kernel.  That's another
>> story. I installed a 32 bit version of Slackware 14.1 with the kernel
>> from the previous version.  But that's not a good test system.
>> In short, my usual test systems are not available.  And I need my
>> other 3 Slackware boxes for work.
>> I appreciate the feedback on systems I simply don't have working right
>> now. I suppose it's time to switch off of Virtualbox and use another
>> virtual system for testing.  I just haven't had time to look into
>> changing my working habits.
>> scott
>> On 11/22/2013 02:20 AM, Willy Sudiarto Raharjo wrote:
>>>> FYI, I tried this and seems to work fine on a pure x86_64 and x86
>>>> (-O2optimizations there should be fine).
>>>> I removed also some bash-specific lines (the interpreter of the
>>>> scripts is set to /bin/sh).
>>> Do you want to put this on your branch or mine?
>> _______________________________________________
>> SlackBuilds-users mailing list
>> SlackBuilds-users-ko+OqhKiB2wsHrnhXWJB8w at public.gmane.org
>> http://lists.slackbuilds.org/mailman/listinfo/slackbuilds-users
>> Archives - http://lists.slackbuilds.org/pipermail/slackbuilds-users/
>> FAQ - http://slackbuilds.org/faq/
> Louis

More information about the SlackBuilds-users mailing list