[Slackbuilds-users] Problem with mono (and probably mono2) on Slackware64

Christoph Willing chris.willing at iinet.net.au
Mon Aug 10 04:30:29 UTC 2015

On 10/08/15 14:10, Ryan P.C. McQuen wrote:
> On 8/9/15, Christoph Willing <chris.willing at iinet.net.au> wrote:
>> On 10/08/15 04:56, Thomas Szteliga wrote:
>> [snip]
>>> Then I found this <https://bugzilla.xamarin.com/show_bug.cgi?id=24131>
>>> and after correcting the wrong path `/usr/lib/libMonoPosixHelper.so` to
>>> `/usr/lib64/libMonoPosixHelper.so` in `/etc/mono/config` everything
>>> worked as expected.
>> That is not an appropriate patch; it is completely 64bit-centric, just
>> as the config in the source code is completely 32bit-centric.
>> I forwarded a "neutral" patch to the maintainer about two months ago -
>> he said he would review it and submit an update. In the meantime,
>> version 4.x.x is available which includes its own fix for the problem
>> (actually, some of the later 3.x.x versions after the SBo version also
>> had the fix).
>> The latest version I tried was and it works fine without patching.
>> chris
> Christoph,
> Is there a neutral patch for mono2?

I just had a look at 2.10.9 and it seems corrected already (like the 
later 3.x.x versions). In data/config.in, the relevant line is:
     <dllmap dll="MonoPosixHelper" 
target="libMonoPosixHelper at libsuffix@" os="!windows" />

In 3.10.0, this incorrectly has an absolute path to @prefix@/lib/ in 
front of libMonoPosixHelper at libsuffix@.


More information about the SlackBuilds-users mailing list