[Slackbuilds-users] Upgrading texlive on 14.1
rshepard at appl-ecosys.com
Sat Jun 24 18:46:43 UTC 2017
Until I finish building/installing my new server/workstation I'm running
14.1/x86_i586 on this host. It has texlive-2014 installed (which works OK);
I want to upgrade to texlive-2016 because I use LaTeX/LyX for > 90% of my
writing. I've hit a wall and would like advice.
Texlive would not build because the poppler library version
(poppler-0.24.3) is too old; it wants a version >= 0.30. It's likely that
the poppler-data version is also too old, but that's not yet been
I downloaded the 14.2 poppler source, build script, and desc. It fails to
complete because of this error:
make: Entering directory /tmp/poppler-0.45.0/qt4/src'
In file included from poppler-optcontent.cc:429:0:
poppler-optcontent.moc:13:2: error: #error "This file was generated using
the moc from 4.2.2. It"
#error "This file was generated using the moc from 4.2.2. It"
poppler-optcontent.moc:14:2: error: #error "cannot be used with the include
files from this version of Qt."
#error "cannot be used with the include files from this version of Qt."
poppler-optcontent.moc:15:2: error: #error "(The moc has changed too much.)"
#error "(The moc has changed too much.)"
Installed here are both qt-4.8.7 and qt5-5.5.1. In poppler.Slackbuild is
which should find the 4.8.7 version.
I've no idea where poppler-optcontent.moc originates. Is there a way for
me to correct this error?
More information about the SlackBuilds-users