[Slackbuilds-users] Anybody else having problems with zoom in 15.0?

Luveh Keraph 1.41421 at gmail.com
Wed Jan 25 14:07:48 UTC 2023

That matches what I observed under Xfce. The Xfce people seem to be as much
in the dark as we are about this, while acknowledging that there are issues
with their xfce4-panel code. However, since it shows up under KDE as well,
we are back to square one. I played a bit with a LD_LIBRARY_PATH in a
shell, but to no avail. I tried first with export
LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/opt/zoom-linux/cef, and then ldd zoom
claims that libQt5Core.so.5 can't be found. I then did export
LD_LIBRARY_PATH=/usr/lib64:$LD_LIBRARY_PATH in the same shell, and this
time I get no complaints from ldd zoom. However, when trying to invoke zoom
directly I get

./zoom: symbol lookup error: ./zoom: undefined symbol:
version Qt_5

ZoomLauncher still does nothing at all.

Interestingly, there is a libQt5Core.so.5 entry under /opt/zoom-linux, but
setting LD_LIBRARY_PATH to pick it up from there still results in ldd zoom
claiming that version Qt_5.15 can't be found. Either way, the latest zoom
in 15.0 seems to be fubarred.

On Wed, Jan 25, 2023 at 4:00 AM Konrad J Hambrick <kjhambrick at gmail.com>

> On Tue, Jan 24, 2023 at 5:57 PM Luveh Keraph <1.41421 at gmail.com> wrote:
>> By the way, this is happening under Xfce. I do not use KDE. Besides this
>> forum, I am also engaging the Xfce people on this.
>> On Tue, Jan 24, 2023 at 4:37 PM Luveh Keraph <1.41421 at gmail.com> wrote:
>>> Poking around a bit, I noticed that the zoom executable under
>>> /opt/zoom-linux depends on two shared libraries (libcef.so and
>>> libffmpeg.so) that are part of the zoom distribution, but that the zoom
>>> executable can't find. But, perhaps it is the case that you are not
>>> supposed  to invoke this executable directly. Indeed, in /opt/zoom-linux as
>>> well there is an executable named ZoomLauncher. When I invoke it from the
>>> command line, the diagnostics that I mentioned above are generated in the X
>>> server log - and that's all: ZoomLauncher returns after one or two seconds,
>>> and nothing else happens. Unfortunately, zoom and ZoomLauncher are
>>> binaries, and they don't print out anything when invoking them with obvious
>>> options, like -h, -? or --help. I am stymied.
>>> On Tue, Jan 24, 2023 at 3:17 PM Luveh Keraph <1.41421 at gmail.com> wrote:
>>>> I have not used zoom for a while in 15.0, but I recall it used to work.
>>>> It does not seem to for me with the latest upgrade.
>>>> When I click on a zoom meeting link that I have received in an email, a
>>>> new tab is opened in my browser (Chromium) where there is a button labeled
>>>> Launch Meeting. When I click on it  I get a popup window asking me whether
>>>> xdg-open is to be invoked. When I go ahead, nothing happens. I get not
>>>> diagnostics in /var/log/syslog or /var/log/messages, but I get the
>>>> following in my X server log:
>>>>  (wrapper-2.0:1749): GLib-GObject-WARNING **: 15:11:49.394: instance
>>>> with invalid (NULL) class pointer
>>>> (wrapper-2.0:1749): GLib-GObject-CRITICAL **: 15:11:49.394:
>>>> g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed
>>>> (wrapper-2.0:1749): libsystray-CRITICAL **: 15:11:49.394:
>>>> sn_item_invalidate: assertion 'XFCE_IS_SN_ITEM (item)' failed
>>>> Any ideas on what is going on, and how to fix it?
>>  Luveh Kerap --
> This is happening on my Slackware64 15.0 KDE Desktop as well.
> I know it worked last week when I needed it.
> I am missing the same two libraries:
> # ldd /opt/zoom-linux/zoom |grep found
>         libcef.so => not found
>         libffmpeg.so => not found
> However, they exist under the /opt/zoom-linux tree:
> # ls -lad $(find /opt/zoom-linux -type f -name "*.so*" |grep -e ffmpeg -e
> libcef)
> -rwxr-xr-x 1 root root 197039432 Sep  6 03:37
> /opt/zoom-linux/cef/libcef.so*
> -rwxr-xr-x 1 root root   3198712 Jan 16 03:10
> /opt/zoom-linux/cef/libffmpeg.so*
> Maybe /usr/bin/zoom-linux needs to be a shell script with ldconfig goodies
> ?
> I am tied up at work this week so no time to mess with it but I might
> start there ?
> -- kjh
> _______________________________________________
> SlackBuilds-users mailing list
> SlackBuilds-users at slackbuilds.org
> https://lists.slackbuilds.org/mailman/listinfo/slackbuilds-users
> Archives - https://lists.slackbuilds.org/pipermail/slackbuilds-users/
> FAQ - https://slackbuilds.org/faq/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.slackbuilds.org/pipermail/slackbuilds-users/attachments/20230125/845f032c/attachment.htm>

More information about the SlackBuilds-users mailing list