[Slackbuilds-users] Updates - 20231118.1

Giancarlo Dessì slack at giand.it
Sat Nov 25 06:17:27 UTC 2023

Il 20/11/23 18:06, Erich Ritz via SlackBuilds-users ha scritto:
> On Friday, November 17th, 2023 at 8:26 PM, Willy Sudiarto Raharjo<willysr at slackbuilds.org>  wrote:
>> Sat Nov 18 02:16:51 UTC 2023
>> libraries/wxWidgets: Updated for version 3.2.4.
> I think this broke the audacity build.
> Here is my slackrepo hint file for audacity:
> # cat /var/lib/slackrepo/etr/hintfiles/audacity.hint
> ADDREQUIRES="jack ladspa_sdk soundtouch twolame vamp-plugin-sdk vst3sdk lilv suil"
> And here is a sampling of the build log:
> /usr/include/wx-3.2/wx/arrstr.h:353:20: error: cannot convert ‘const wxArrayString’ to ‘wxArrayString::const_reference’ {aka ‘const wxString&’}
>    353 |           push_back(*first);
>        |           ~~~~~~~~~^~~~~~~~

I've found the same error with audacity 3.3 in current.

I solved by building audacity 3.4.2 (the slackbuild works fine as is 
actually without any changes). First, an error occurred without 
lilv+suil installed. Since lv2 is an optional dependency I think a patch 
is needed if are not installed, but I solved installing also lilv and 
suil instead to find a patch. With these dependencies installed in the 
system the build of audacity 3.4.2 ends successfully.

I didn't tested this solution in stable Slackware 15.0

Giancarlo Dessì

Slackware Linux... because it works!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.slackbuilds.org/pipermail/slackbuilds-users/attachments/20231125/afbac3a2/attachment.htm>

More information about the SlackBuilds-users mailing list