[Slackbuilds-users] The joys of building qemu and kqemu

Audrius Kažukauskas neobug at tornado.ktu.lt
Mon Feb 26 18:34:43 UTC 2007


After few hours of frustration compiling and recompiling (thank goodness
there's a tool like ccache), reading documentation and almost wanting to
bang my head in the wall I finally got qemu acceleration working.

At first after installing both qemu and kqemu packages I copied
rc.kqemu, which comes with kqemu.SlackBuild from SBo, to /etc/rc.d/ and
executed it.  /dev/kqemu was created, it was readable and writable to
all, lsmod showed that kqemu module was also loaded.  But every time I
tried to run qemu, I always got the annoying

  "Could not open '/dev/kqemu' - QEMU acceleration layer not activated"

message.  I thought that maybe newest kqemu needs qemu-0.9.0, so I built
the package containing new version and, alas, still got the same.
Later, scanning through http://qemu.org/kqemu-doc.html#SEC4 my eyes
caught attention to very hopefully looking line:

  echo 'KERNEL=="kqemu", NAME="%k", MODE="0666"' \
       > /etc/udev/rules.d/60-kqemu.rules

So I tried it and... it finally worked!  What a joyful moment it was!

So it appears that at least in my situation udev rules file was
required, and I am writing this with hope that it would be useful to
anyone else who might get into similar problems.

By the way, it would be nice to put a line like this

  find $PKG/usr/share -type f -size 0 -exec rm -f {} \;

into qemu.SlackBuild, because qemu build process generates some strange
randomly named empty file, which, I think, is useless.

Audrius Kažukauskas
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.slackbuilds.org/pipermail/slackbuilds-users/attachments/20070226/aaa8296e/attachment-0002.bin 

More information about the Slackbuilds-users mailing list