[Slackbuilds-users] nicotine: segmentation fault

Iskar Enev iskar.enev at gmail.com
Thu Mar 15 14:54:34 UTC 2007

No, you don't have to upgrade gtk+-1.2.10. I meant upgrading gtk+2 
(which is just version 2 of GTK+) to version 2.10. As Robby Workman said 
such upgrade wouldn't be without issues.

May be you could downgrade pygtk to version 2.8.x and see if it works 
with your version of gtk+2 (was 2.8 i think).

Iskar Enev

Martin Ivanov wrote:
> I even tried running nicotine directly from the untarred sources, but I again got segmentation fault. I notice that in nicotine's site they say it requires GTK+-2.0 or newer (GTK+-2.2 recommended), while in my Slackware 11.0 system I have:
> /var/adm/packages/gtk+-1.2.10-i386-3
> /var/adm/packages/gtk+2-2.8.20-i486-1
> Which of the two packages do I have to upgrade? What is actually the difference between gtk+2 and gtk+ ?
> It seems to me that I have to upgrade gtk+-1.2.10-i386-3 to gtk+-2.2, but won't it cause trouble to my system?
> I also notice that they suggest that if one compiles pygtk on his own, one has to pass --enable-thread to ./configure ... which has not been done in pygtk's configure in the slackbuild. 
> Regards,
> Martin
> -----------------------------------------------------------------
> http://auto-motor-und-sport.bg/ 
> С бензин в кръвта
> _______________________________________________
> Slackbuilds-users mailing list
> Slackbuilds-users at slackbuilds.org
> http://lists.slackbuilds.org/mailman/listinfo/slackbuilds-users

More information about the Slackbuilds-users mailing list