[Slackbuilds-users] lyx_qt4 slackbuild fails during make

Bob Lounsbury boblounsbury at gmail.com
Thu Jan 10 18:44:53 UTC 2008

On Jan 8, 2008 10:15 PM, Robby Workman <rworkman at slackbuilds.org> wrote:
> Aleksandar B. Samardzic wrote:
> > On Jan 3, 2008 8:02 PM, Robby Workman <rworkman at slackbuilds.org> wrote:
> >> Heinz Wiesinger wrote:
> >>
> >>>> Good point on that, but interestingly enough, I've got 4.3.3 done here
> >>>> and I *thought* I'd updated it in our repo :/  You okay with me doing
> >>>> that?
> >>> You got my okay. Worked fine for me, but it's not my script.
> >>> Alex?
> >>
> >> Oops, yeah.  Alex?  :)
> >>
> >> -RW
> >
> > Hi guys,
> >
> > I'm using Qt 4.3.3 too, from the day it was released, and it worked
> > fine for me; haven't bothered to post an update of my qt4 SlackBuild
> > since I understood, from a recent discussion, that preferred behavior
> > would be to *not* post an update when version bump only needed (as is
> > the case here).
> >
> > So, Robby:
> > - Feel free to update qt4 script.
> > - If you could provide any additional info regarding problems with
> > building Qt 4 on the other box you mentioned, I'd certainly like to
> > hear, and to try to debug.
> Well, this is a long shot, but it seems that there's something to it.
> While talking to the guy in my LUG (really just spouting random ideas
> that I really didn't think had any merit), one of the things brought
> up was the fact that both of the failing builds are being done on
> older hardware (P3 for both iirc).  Vincent (the LUG guy) decided to
> try passing -nosse and -nosse2 to qt's configure, and last I talked
> to him, it was still building happily -- not finished, but well past
> the point it had been throwing the ICE (internal compiler error).
> So... if any of you have an P3 or older hardware not doing anything
> useful, how about starting a qt4 build on it (don't modify anything
> yet) and see what happens?
> -RW

Just my luck, it didn't help adding the -nosse and -nosse2 options.
Adding these options actually made the internal compiler error occur
right after the end of the configure. Without those options make
continues for a few minutes.

For clarification, I'm using an AMD Athlon 2000+ processor. Don't know
if that affects the options needed for the qt configure? Hopefully,
I'm crossing my fingers, I just need to change an option.

Thanks for the help.

More information about the Slackbuilds-users mailing list