[Slackbuilds-users] Problems with Graphviz

Audrius Kažukauskas neobug at tornado.ktu.lt
Thu Oct 30 12:09:20 UTC 2008

On Wed, 2008-10-29 at 14:10:59 -0700, Rich Shepard wrote:
>   I've still not had time to upgrade my main server/workstation from
> Slackware-11.0. I downloaded graphviz-2.12 along with the SlackBuild files,
> and built that after building and installing swig.
>   When I test by running 'dot -T?' to learn what formats are supported, I'm
> told:
> dot: error while loading shared libraries: libgraph.so.4: cannot open shared
> object file: No such file or directory
>   A soft link didn't help.
>   Then I tried building graphviz-2.20.3. This time I get te analogous error,
> dot: error while loading shared libraries: libgraph.so.3: cannot open shared
> object file: No such file or directory
> Again, a soft link doesn't help.

Hmm, that's strange.  I'm not sure where the problem could be.  (And I
think that you mixed up libgraph.so error messages, because
graphviz-2.20.3 uses .4, not .3)

Here's how it looks in my system:

  $ dot -T?
  Format: "?" not recognized. Use one of: bmp canon cmap cmapx cmapx_np
  dia dot eps fig gd gd2 gif gtk hpgl ico imap imap_np ismap jpe jpeg
  jpg mif mp pcl pdf pic plain plain-ext png ps ps2 svg svgz tif tiff tk
  vml vmlz vrml vtx wbmp xdot xlib

  $ ldd `which dot` | grep libgraph
          libgraph.so.4 => /usr/lib/libgraph.so.4 (0xb8048000)

  $ ls -l /usr/lib/libgraph.so.4
  lrwxrwxrwx 1 root root 17 2008-10-11 14:34 /usr/lib/libgraph.so.4 ->

Maybe something went wrong while creating symlinks in doinst.sh during
the package installation?

Audrius Kažukauskas
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: not available
URL: <http://lists.slackbuilds.org/pipermail/slackbuilds-users/attachments/20081030/766f1e4a/attachment.sig>

More information about the SlackBuilds-users mailing list