[Slackbuilds-users] VirtualBox

Audrius Kažukauskas neobug at tornado.ktu.lt
Fri Sep 26 11:53:49 UTC 2008

On Fri, 2008-09-26 at 13:32:29 +0200, Heinz Wiesinger wrote:
> > I think menu entry is missing probably due to non-existent VirtualBox
> > executable in $PATH.
> nope. kde looks for .desktop files in certain directories, in this 
> case /usr/share/applications/

I understand that, but VirtualBox.desktop points to VirtualBox and since
it is missing, maybe KDE4 just ignores the menu entry (not that I know
this for sure...).

> > No /usr/bin/VirtualBox.  /usr/bin/VBox exists, but trying to run it
> > gives me "Unknown application - VBox" output.
> This and the menu problems leaves the assumption that doinst.sh didn't get 
> executed on installation. Further symptoms could be non-existent VBoxManage, 
> VBoxSDL, VBoxHeadless and some more in /usr/bin.

  $ VBox<tab><tab>
  VBox          VBoxDeleteIF  VBoxManage    VBoxTap       VBoxVRDP
  VBoxAddIF     VBoxHeadless  VBoxSDL       VBoxTunctl

Running some of those (for example VBoxManage) outputs version and usage
information, so here everything looks fine.

> If that is the case there is the question why it didn't get executed. Have you 
> installed it with install-/upgradepkg?

I installed it with upgradepkg over the 2.0.0 (which had the same
symptoms, but I just hadn't free time to figure things out and assumed
that it may be a problem with 2.0.0 version).

> You could maybe try reinstalling the same package and look if doinst.sh gets 
> executed.

Tried upgradepkg --reinstall.  It's still the same.

Audrius Kažukauskas
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: not available
URL: <http://lists.slackbuilds.org/pipermail/slackbuilds-users/attachments/20080926/6e7ea077/attachment.sig>

More information about the SlackBuilds-users mailing list