[Slackbuilds-users] pygobject issue

Robby Workman rworkman at slackbuilds.org
Mon Oct 19 04:16:39 UTC 2009

On Sun, 18 Oct 2009 19:19:03 +0200
Marco Cecchetti <mrc.ildp at gmail.com> wrote:

> Building python-clutter I run into this error:

python-clutter or python-cluster?  We don't have python-clutter
in our repo, but maybe it's something you're working on outside
of SBo for the time being.  It doesn't really matter in the 
context of the problem report, but I'm just curious... :-)

> make[4]: execvp: /usr/share/pygobject/xsl/fixxref.py: Permission
> denied
> Is "fixxref.py" file expected to be executable?
> I think it should be. Changing the permission works.

Well, I wouldn't expect something in /usr/share to need executable
bit set, but apparently python-clu(s|t)ter does.  That file is not
executable in pygobject-2.18.x either, so I suspect one of these
two situations is accurate:

  1. It's a bug in pygobject that other upstream projects have
     worked around by calling the python script differently.

  2. It's a bug in python-clu(s|t)ter with expecting something that
     can't reasonably be expected.

Finding out which one is likely to be fun, and quite frankly, I'd
start with the python-clu(s|t)ter devs to see what they think.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
URL: <http://lists.slackbuilds.org/pipermail/slackbuilds-users/attachments/20091018/1e79bb7e/attachment.asc>

More information about the SlackBuilds-users mailing list