[Slackbuilds-users] gksu set of packages not working

Aaditya Bagga aaditya_gnulinux at zoho.com
Thu Dec 5 14:11:15 UTC 2013

I was confused for a moment because I saw that gksu and libgksu had 
But then I went to the gksu url and saw that gksu was being replaced by 
gksu Polkit.

I wanted to use gksu to use the root Thunar option in menu.(I dont think 
it will work with su)
So I searched and found this-
http://mail.xfce.org/pipermail/xfce/2012-May/030479.html (Running 
graphical programs as root 
This uses zenity, but with it I am able to do what I want :)

On 12/05/2013 03:57 PM, Willy Sudiarto Raharjo wrote:
> Hash: SHA1
>> hello, there seems to be a bug with the gksu set of packages
>> (libgtop+libgksu+gksu). they all built and installed, but I get an
>> error when I run it.
>> There's a thread on LQ about this,
>> https://www.linuxquestions.org/questions/slackware-14/solved-can%27t-get-gksu-to-work-784919/
>> I first got this error "The gksu-run-helper command was not found or
>> is not executable."
>> Then I did "mkdir /usr/lib/libgksu
>>   ln -s /usr/lib64/libgksu/gksu-run-helper
>> /usr/lib/libgksu/gksu-run-helper"
>> and got this error-"Failed to communicate with gksu-run-helper.
>>   Received:
>>   ssword:
>>   While expecting:
>>    gksu: waiting"
> For now, the solution is to use su
> libgksu and gksu are no longer maintained, so i guess it's time to say
> good bye as no other packages depends on gksu either
> - --
> Willy Sudiarto Raharjo
> Version: GnuPG v2.0.22 (GNU/Linux)
> Comment: Using GnuPG with Thunderbird -http://www.enigmail.net/
> MsIAnRjzddyKkg3kscvINmwprNqRZVV7
> =fmv2

More information about the SlackBuilds-users mailing list