[Slackbuilds-users] slackbuild(s) failing on S14.1-64 when compat32 installed

Jim Diamond Jim.Diamond at acadiau.ca
Sat Dec 21 17:30:05 UTC 2013

Hi all,

I have a couple of 64-bit 14.1 systems, one with Alien Bob's multilib
(compat32) packages installed.

Some slackbuild packages which compile flawlessly under "vanilla"
64-bit Slackware crash and burn under 64bit+multilib.

For example, I just tried to build GraphicsMagick on a Slackware 64
14.1 system with the compat32 stuff installed.

The build failed with

libtool: link: rm -f ltdl/.libs/libltdlc.nm ltdl/.libs/libltdlc.nmS
libtool: link: (cd ltdl/.libs && gcc -std=gnu99 -O2 -fPIC -Wall -pthread -c
-fno-builtin  -fPIC -DPIC "libltdlcS.c")
libtool: link: rm -f "ltdl/.libs/libltdlcS.c" "ltdl/.libs/libltdlc.nm"
"ltdl/.libs/libltdlc.nmS" "ltdl/.libs/libltdlc.nmT"
libtool: link: (cd ltdl/.libs/libltdlc.lax/dlopen.a && ar x
libtool: link: ar cru ltdl/.libs/libltdlc.a
ltdl/.libs/ltdl_libltdlc_la-lt_error.o ltdl/.libs/ltdl_libltdlc_la-ltdl.o
ltdl/.libs/ltdl_libltdlc_la-slist.o ltdl/.libs/lt__strl.o
ltdl/.libs/libltdlcS.o  ltdl/.libs/libltdlc.lax/dlopen.a/dlopen.o
libtool: link: ranlib ltdl/.libs/libltdlc.a
libtool: link: rm -fr ltdl/.libs/libltdlc.lax
libtool: link: ( cd "ltdl/.libs" && rm -f "libltdlc.la" && ln -s
"../libltdlc.la" "libltdlc.la" )
/usr/bin/grep: /usr/lib/liblzma.la: No such file or directory
/usr/bin/sed: can't read /usr/lib/liblzma.la: No such file or directory
libtool: link: `/usr/lib/liblzma.la' is not a valid libtool archive
make[1]: *** [magick/libGraphicsMagick.la] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory `/tmp/SBo/GraphicsMagick-1.3.17'
make: *** [all] Error 2

The system does have /usr/lib64/liblzma.la, which I think is what it
should be looking for.

In the past I have convinced some such packages to compile by applying
some brute force.  In the slackbuild script, after the configure step
is done, I used 

for f in `grep -r L/usr/lib . | sed "s/:.*//"`
    echo $f ; - sed -i 's?-L/usr/lib ?-L/usr/lib64 ?' $f

However, that's pretty grotesque.

Does anyone on this list know The Right Thing to do?
And, if so, should the slackbuilds be updated to deal with this issue?



P.S. I tried to email Giovanne (since he is the GraphicsMagick
slackbuild maintainer) but the addr on the GraphicsMagick slackbuild
page bounced.

More information about the SlackBuilds-users mailing list