[Slackbuilds-users] Qemu-kvm

John Yost alleytrotter at gmail.com
Tue May 7 00:31:48 UTC 2013

On 05/06/2013 06:20 PM, Sebastian Arcus wrote:
> On 06/05/13 13:36, John Yost wrote:
>> On 05/05/2013 11:57 PM, King Beowulf wrote:
>>> On 05/05/2013 12:14 PM, John Yost wrote:
>>>> On 05/04/2013 11:37 PM, King Beowulf wrote:
>>>>> On 05/04/2013 02:47 PM, John Yost wrote:
>>>>>> I tried to upgrade to the latest Qemu version 1.4.0. The
>>>>>> upgrade went fine. I did not use usbdir or spice, just the
>>>>>> basic Qemu. When I tried to start the VM with my usual
>>>>>> command line .....
>>>>>> "qemu-kvm -usb -ctrl-grab -m 4096 -soundhw es1370 -localtime
>>>>>> -vga std -cdrom /dev/cdrom /mnt/other/VM/winxp.img"
>>>>> ---snip--------
>>>> I thought there was supposed to be a simple default network
>>>> connection without any needed setup. The qemu manpage seems to
>>>> indicate there is a default automatic network connection. Any
>>>> direction would be greatly appreciated. Don't know how many times
>>>> Xp can be re-certified before I get refused.
>>> Since WinXP is dead its anyone's guess how long the activation
>>> servers will be up.  There are ways to bypass activation.
>>> I dredged up my old WinXP CD and fired up a VM (I will never
>>> forgive you foe that!).  Looks like qemu uses a default nic that
>>> WinXP does not recognize, even after installing Service Pack 3.
>>> Here is my command to have WinXP automagically detect and install
>>> the NIC driver (adjust as needed)
>>> $ qemu-kvm -m 768 -hda winxp.img -cdrom /dev/dvd -net
>>> nic,model=pcnet -net user
>>> Adjust as needed.
>>> For the future:
>>>  From the qemu manpage: "The NIC is an e1000 by default on the PC
>>> target." Now check WinXP device manager, ooo! yellow ? for
>>> ethernet controller; right click properties, update driver, etc etc
>>> look at driver list....mmm no driver, lets try another nic ...
>>> Just sayin'...
>>> -Ed
>> Please forgive me. I use xp once a month to access bank. Otherwise I
>> retired windows in general before y2k.....
>> Your solution worked fine. I did tread on that trail with the yellow
>> ?, but apparently did not go far enough.
>> I will investigate the bypass for future access. Any pointers?
>> thanks
>> john
> I've had to deal with a similar issue few weeks ago when installing a
> Windows 7 guest. There are several factors at play:
> 1. Qemu uses an "old" and a "new" way of specifying network interfaces
> for the guest. The old way is just "-net nic,model=<model>". This is
> supposed to be obsolete, but still works. According to the manual, you
> can try to start qemu with:
> -net nic,model=?
> and you will get a list of all the models of network cards qemu can
> provide.
> 2. One option might be to do the above, then try one model at a time
> until you find one XP supports out of the box.
> The following page has a list of NIC models supported by qemu - I'd say
> there is a very good chance that rtl8139 is supported by Windows XP
> without additional drivers.
> http://en.wikibooks.org/wiki/QEMU/Devices/Network
> Also, the ne2000 is a very old model, so I would be really surprised if
> XP doesn't have integrated drivers.
> 3. Failing the above, another option (which is what I did), is to
> download the iso cdrom image for the virtio drivers provided by RedHat:
> http://alt.fedoraproject.org/pub/alt/virtio-win/latest/images/
> Download the iso image, and start kvm with it attached as an extra
> cdrom. The following option should do (using the index setting, in case
> you have another cdrom as well):
>     -drive file=virtio-win-0.1-59.iso,media=cdrom,index=1 \
> At the same time you would start your vm with a virtio NIC as well:
>     -netdev user,id=mynic \
>     -device virtio-net-pci,netdev=mynic \
> When adding the three option lines from above to your qemu start
> command, it will start your vm with the RedHat drivers cd attached, and
> a virtio NIC. Then, in Windows, you can install the virtio NIC drivers
> from the attached CD - and you should have access to the Internet.
> Sorry for the rather disjointed explanation - hope it helps.
All is
OK now with King Beowolf's suggestion "-net nic,model=pcnet -net user"

It seems changing the network interface card was most likely triggering
the re-certification requirement as it counts for 3 votes.
There must have been a change in the default network interface card
between versions 1.2.0 and 1.4.0, Anyway I will now be careful to define
the nic on the cmdline which starts qemu.
thanks for the additional info.

More information about the SlackBuilds-users mailing list