[Slackbuilds-users] xen again

Paul McCormack islandmarmot at gmail.com
Sat Aug 16 15:51:28 UTC 2014

I'm not sure that my first post made it through so the humour may be 
lost but here goes.

I have a dom0 running on Slackware64 14.1, 3.10.17 with multilib and 
updated using slackpkg "Slackware64 14.1"

xl list gives me

Name ID Mem VCPUs State Time(s)

Domain-0 0 512 4 r----- 9.2

I built the domU image as per the slackbuild and I can mount it. I 
modified the script to install from a USB drive. This works but lilo did 
not run.

when I try to create the domain xl panics..

In the mydom config file the first two lines are

kernel = "/boot/vmlinuz-xen"

ramdisk = "/boot/initrd-xen.gz"

So I'm a little confused as I expected to see

kernel = "/boot/vmlinuz"

ramdisk = "/boot/initrd.gz"

Checking the slackware.img /boot/vmlinuz -> /boot/vmlinuz-huge-3.10.17

I guess that the way forward is to either copy the "*-xen" files to 
mnt/boot and or run mkinitrd.

I think the former due to fact that we symlink lib/modules/3.10.17-xen 
to lib/modules/3.10.17

ok tried that - copied vmlinuz-xen and initrd-xem.gz over to boot no change

xl create -c mydom results in.........


Parsing config from mydom

xc: error: panic: xc_dom_bzimageloader.c:655: 
xc_dom_probe_bzimage_kernel: boot protocol too old (0203): Invalid kernel

xc: error: panic: xc_dom_core.c:621: xc_dom_find_loader: no loader 
found: Invalid kernel

libxl: error: libxl_dom.c:384:libxl__build_pv: xc_dom_parse_image 
failed: No such file or directory

libxl: error: libxl_create.c:900:domcreate_rebuild_done: cannot 
(re-)build domain: -3


am I heading in the right direction here? I've tried searching and can't 
figure it out.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.slackbuilds.org/pipermail/slackbuilds-users/attachments/20140816/8ec7e3f2/attachment-0001.html>

More information about the SlackBuilds-users mailing list