[Slackbuilds-users] building qt5 apps

Miguel De Anda miguel at thedeanda.com
Fri Feb 6 07:46:42 UTC 2015

I had done it months ago and it was fine. Tried it now assuming qt was
statically linked but it actually works with qt 5.4.0. If I uninstall qt5
and run ldd I get:

$ldd ./lib/Fritzing
        linux-vdso.so.1 (0x00007fff26d30000)
        libz.so.1 => /lib64/libz.so.1 (0x00007f0126a70000)
        libQt5PrintSupport.so.5 => not found
        libQt5Svg.so.5 => not found
        libQt5Widgets.so.5 => not found
        libQt5SerialPort.so.5 => not found
        libQt5Sql.so.5 => not found
        libQt5Network.so.5 => not found
        libQt5Xml.so.5 => not found
        libQt5Gui.so.5 => not found
        libQt5Core.so.5 => not found
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f0126850000)
        libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007f0126548000)
        libm.so.6 => /lib64/libm.so.6 (0x00007f0126240000)
        libgcc_s.so.1 => /usr/lib64/libgcc_s.so.1 (0x00007f0126028000)
        libc.so.6 => /lib64/libc.so.6 (0x00007f0125c68000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f0126cd8000)

However, installing qt5 package built yesterday from the sbo script it

I'll keep retrying. Maybe I'm doing something silly.


On Thu, Feb 5, 2015 at 10:36 PM, B Watson <yalhcru at gmail.com> wrote:

> On 2/6/15, Miguel De Anda <miguel at thedeanda.com> wrote:
> > so, that kind of puts me in a tough spot. should i just use the binary
> and
> > have it build a package from that or wait for fritzing to compile on
> 5.4+?
> >
> > any thoughts?
> Have you actually tried running the binary package? I bet it won't
> work, whatever's preventing it from compiling will likely prevent it
> from running too.
> _______________________________________________
> SlackBuilds-users mailing list
> SlackBuilds-users at slackbuilds.org
> http://lists.slackbuilds.org/mailman/listinfo/slackbuilds-users
> Archives - http://lists.slackbuilds.org/pipermail/slackbuilds-users/
> FAQ - http://slackbuilds.org/faq/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.slackbuilds.org/pipermail/slackbuilds-users/attachments/20150205/eed02ed7/attachment.html>

More information about the SlackBuilds-users mailing list