[Slackbuilds-users] pysetuptools 8 implements PEP 440

Audrius Kažukauskas audrius at neutrino.lt
Sun Feb 8 18:10:58 UTC 2015

On Mon, 2014-12-22 at 21:21:17 +0100, Markus Reichelt wrote:
> just a heads-up wrt pysetuptools 8+
> #tahoe-lafs on freenode:
> <dstufft> setuptools 8 implements PEP 440
> <dstufft> PEP 440 makes the meaning of , change from "a bunch of
> arbitrary confusing crap that PJE invented in the past" to "AND"
> related:
> https://gist.github.com/kylemanna/a22e7c37e5ff1f9286c2
> tl;dr: if you can, keep pysetuptools <8

I pushed updates for pysetuptools, pip and virtualenv latest versions.
I feel that we waited long enough for things to settle down, and most of
the issues related to PEP 440 should be solved either by setuptools devs
(if there were any bugs in their code) or by upstream of other projects
depending on setuptools.

Regarding allmydata-tahoe, developers fixed version specifiers in their
Git repo, but there doesn't seem to be any versions released with those
fixes, so I extracted them into a patch (attached).  It works for me
with setuptools 12.0.5, but I only installed allmydata-tahoe and tried
to run "tahoe --version", so please test it and see if everything works

For other maintainers of packages depending on setuptools: if your
package won't build with latest setuptools, see if there's newer version
released.  If there isn't, read PEP 440 version specifier section[*] and
try fixing it yourself, it's not very complicated.  Although in most
cases I expect that everything will work as before.

[*] https://www.python.org/dev/peps/pep-0440/#version-specifiers

Audrius Kažukauskas
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 181 bytes
Desc: not available
URL: <http://lists.slackbuilds.org/pipermail/slackbuilds-users/attachments/20150208/0b08bd07/attachment.asc>

More information about the SlackBuilds-users mailing list