[Slackbuilds-users] pysetuptools 8 implements PEP 440

Markus Reichelt ml at mareichelt.com
Tue Feb 17 21:04:49 UTC 2015

* Audrius Kazukauskas <audrius at neutrino.lt> wrote:

> I pushed updates for pysetuptools, pip and virtualenv latest
> versions.  I feel that we waited long enough for things to settle
> down, and most of the issues related to PEP 440 should be solved
> either by setuptools devs (if there were any bugs in their code) or
> by upstream of other projects depending on setuptools.

Thanks for being patient (and the patch).

> Regarding allmydata-tahoe, developers fixed version specifiers in
> their Git repo, but there doesn't seem to be any versions released
> with those fixes, so I extracted them into a patch (attached).  It
> works for me with setuptools 12.0.5, but I only installed
> allmydata-tahoe and tried to run "tahoe --version", so please test
> it and see if everything works correctly.

allmydata-tahoe 1.10.1 is scheduled to be released soon (couple of
weeks at most).  Compared to 1.10 this version will have more (direct
or indirect) dependencies and the adaptation of that code to PEP 440
is best documented at

According to the Slackware64 buildbot it's all fine, wrt PEP 440:

I plan to check all deps for updates and run tests this weekend.

Naughty little Tahoe-LAFS.

More information about the SlackBuilds-users mailing list