[Slackbuilds-users] FFmpeg update

David Spencer baildon.research at googlemail.com
Mon May 25 20:44:46 UTC 2015

Ok, here is a roundup of what I'm seeing. I've tried to built the
whole of Heinz's list. In all cases the failure is the same on both
x86_64 and i686. If you need to know what deps and options I used,
you're welcome to ask, also there's a log of the i686 build at

(1) audio/audacity fails to build, I've not yet tried fixing it with
John V's solution but the patches look good with relation to the error
messages I see so I'll confirm that tomorrow.

(2) audio/mpd fails to build, again John V's upversion sounds like a
good plan so I'll confirm that tomorrow.

(3) games/alephone fails to build, once again John V has a fix!

(4) games/dolphin-emu fails to build, but the problem is independent
of ffmpeg (it was already broken before the update)

In file included from /usr/include/gtk-3.0/gdk/gdkapplaunchcontext.h:30:0,
                 from /usr/include/gtk-3.0/gdk/gdk.h:32,
                 from /usr/include/gtk-3.0/gtk/gtk.h:30,
/usr/include/gtk-3.0/gdk/gdktypes.h:127:39: error: conflicting
declaration 'typedef struct _GdkWindow GdkWindow'
 typedef struct _GdkWindow             GdkWindow;

(5) multimedia/bombono-dvd fails to build but here's John V has a fix
(yay!) so I'll confirm tomorrow

(6) multimedia/cinelerra fails to build, it's odd because I never
asked for x264 support?

qth264.c:9:18: fatal error: x264.h: No such file or directory
 #include "x264.h"

(7) multimedia/transcode fails to build. I think this is unrelated to
John V's patch. This is a strange problem, under 'optional package
support' it says
lame                           no
(which is correct), but then the build fails as below:

ERROR: option '--enable-lame' failed: cannot link against libmp3lame
libmp3lame can be found in the following packages:
  lame  http://www.mp3dev.org/

(8) multimedia/dvdrip and multimedia/mythtv cannot be built at the
moment due to dependency on transcode

(9) Random other things I noticed during this exercise:

* Can we reconsider ffmpeg's '_custom' ARCH suffix? AFAIK it's the
only such package anywhere, and it breaks slackpkgplus. (I can guess
the reaction to that question!)

* desktop/ffmpegthumbnailer/ffmpegthumbnailer.info on Heinz's branch
should have VERSION="2.0.10"

* network/imageshack-uploader has bad ownership 1000/users for lots of
stuff in the package

* system/ZoneMinder ships the unusual directory /tmp/zm/, I'm not
saying this is wrong, but it is unusual, but what *is* wrong are the
permissions on /tmp that it ships. Also, the doinst.sh calls both
'config etc/rc.d/rc.zm.new' and 'preserve_perms etc/rc.d/rc.zm.new' --
preserve_perms shows an error because etc/rc.d/rc.zm.new has already
been moved when it runs, the 'config' needs to be removed.

Hope this makes sense -- there should be more tomorrow

More information about the SlackBuilds-users mailing list