[Slackbuilds-users] FreeBASIC

J. E. Garrott Sr johnga1 at mindspring.com
Thu Oct 8 06:05:59 UTC 2015

-----Original Message-----
>From: King Beowulf <kingbeowulf at gmail.com>
>Sent: Oct 7, 2015 10:53 PM
>To: slackbuilds-users at slackbuilds.org
>Subject: Re: [Slackbuilds-users] FreeBASIC
>On 10/07/2015 10:27 PM, J E Garrott Sr wrote:
>> The SlackBuild for FreeBASIC does not seem to work on my Slackware64
>> system.  When the package is made and installed, fbc cannot find the
>> libraries.  It looks for them in /usr/lib instead of /usr/lib64.
>> I made my own package (by hand, guess, and bygolly)  :)  I got it to
>> work, then
>> compiled and built a new package.  It still put the libs in /usr/lib, 
>> but this time
>> the path was /usr/lib/freebasic/linux-x86_64.
>> So far I haven't come up with a fix for the current SlackBuild, but
>> thought I'd
>> give a "head's up".  Might save the next one to try it some trouble.
>> John
>Works fine as-is here.
>The freebasic.SlackBuild just repackages the binary files; there is no
>compiling.  Are you certain you downloaded the x86_64 version and not
>the x86 version for Slackware64?
>Are you running multilib and got that scrambled?
Nope, straight 64 bit. I thought maybe I had done that, but I downloaded the files again.
Same result.  I then went to the FreeBASIC site and downloaded the 64 bit version from there.
Still no joy.

I only got it to run when I played with their install.sh  (prefix=/usr make; prefix=package_dir/usr make install).
That worked, then I got the source and recompiled. (It goes fast!).  That worked also as detailed above.


More information about the SlackBuilds-users mailing list