[Slackbuilds-users] [Slackbulds-users] qemu-2.6.0 issue with Windows guests.

Gerardo Zamudio gerardo.zamudio at linux.com
Wed Aug 3 14:28:03 UTC 2016

On 08/03/2016 01:43 AM, King Beowulf wrote:
> On 08/02/2016 12:24 PM, Gerardo Zamudio wrote:
> Are you host-mode or full emulation?  KVM modules loaded?   Note that
> qemu upstream fiddles with the options quite a bit. For example, for 7
> and 10, I use:
> qemu-system-x86_64 -enable-kvm -machine accel=kvm -m 8G \
>     -hda windows7.img -cdrom /dev/dvd -boot order=cd \
>     -cpu host -smp 4 -name "Windows7pro64" -soundhw hda \
>     -vga std -sdl -display gtk -usb \
>     -netdev user,id=mynet1,hostname=win7vm,smb=/games/win32/ \
>     -device virtio-net-pci,netdev=mynet1,mac=52:54:00:35:a6:50
> (some redundancy but meh...)
> also, what image file (qcow2 etc) set up is can impact performance as
> well as your host hard drive configuration and format.
> My hard drive speed with qemu-2.6 in XP, 7 and 10 is not stellar, but
> plenty good enough.

I'm using full emulation and KVM modules are loaded. I've tried various
combinations of virtual hardware (IDE, SATA, etc), disk drivers (virtio,
, cache settings, image types, etc. I use virt-manager to create and
manage my virtual machines. On my system I can do

installpkg qemu-2.4 , and a new Windows installation is complete in less
than 10 minutes

removepkg qemu-2.4

installpkg qemu-2.6 , and a new Windows install is stuck in "Starting

Note that both packages were built on fresh systems using the
SlackBuilds (install Slackware 14.2, build qemu-2.4, wipe drive, install
Slackware 14.2, build qemu-2.6). I've tried building both packages from
source on fresh systems on different hardware but I get the same results.

It may have something to do with the build options.

Using your example, I have the same problem on 2 different hardware :

qemu-system-x86_64 -enable-kvm -machine accel=kvm -m 4G \
-hda .virtualmachines/win7.img \
-cdrom .iso/Windows7Professionalx64SP1.iso \
-boot order=cd -cpu host -smp 4 -name "Windows7pro64" \
-soundhw hda -vga std -sdl -display gtk \
-usb -netdev user,id=mynet1,hostname=win7vm \
-device virtio-net-pci,netdev=mynet1,mac=52:54:00:35:a6:50

Do you have a copy of your qemu-2.6 binary? I'm willing to give that a
go. It should help me figure out if I'm doing something wrong

Gerardo Zamudio

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 801 bytes
Desc: OpenPGP digital signature
URL: <http://lists.slackbuilds.org/pipermail/slackbuilds-users/attachments/20160803/c86846e2/attachment.asc>

More information about the SlackBuilds-users mailing list