[Slackbuilds-users] Segmentation fault when trying to build SpamAssassin

Sebastian Arcus s.arcus at open-t.co.uk
Thu Aug 4 16:39:56 UTC 2016

On 02/08/16 17:00, Willy Sudiarto Raharjo wrote:
>> I am getting a segmentation fault when trying to build SpamAssassin from
>> SBo. The machine specs are:
>> Perl 5.22.2
>> Slackware 64 bits - updated about 2 weeks ago, after 14.2 release
>> Kernel 4.4.14
>> The error is:
>> ./spamassassin.SlackBuild: line 78:  1854 Segmentation fault
>> PERL_MM_USE_DEFAULT=1 perl Makefile.PL PREFIX=/usr INSTALLDIRS=vendor
>> I've tried on two different machines, with similar spec and software
>> versions - and get the same error. Has anybody else seen this? As these
>> machines were upgraded, not freshly installed, could it be something to
>> do with older perl modules still floating about? Could anybody check to
>> see if SpamAssassin still builds against a current install please.
> Try this
> remove all perl packages from SBo and reinstall SpamAssassin along with
> all the deps from scratch.
> As ponce said many times, perl in 14.2 is not fully backward compatible
> with 14.1 so all perl packages must be recompiled against 14.2's perl

Thank you Willy and ponce. I just got round to trying this - I removed 
the all various CPAN dirs manually, as I previously installed modules 
using CPAN, then uninstalled and re-installed Perl and then re-installed 
all required modules. Now Spamassassin compiles fine. A bit of a pain, 
but it worked! Thank you

More information about the SlackBuilds-users mailing list