[Slackbuilds-users] Problem building qt5 on 14.2

Jim Diamond Jim.Diamond at acadiau.ca
Tue Aug 30 23:57:00 UTC 2016

On Tue, Aug 30, 2016 at 22:42 (+0200), flupi at mclink.it wrote:

> I applied the patch on the gcc bugzilla and rebuilt the system compiler.
> Now the two short sources compile without errors, but still I can't compile
> qt5.

> Next I tried installing the compiler from "current" but I still get the same
> error.   Notice that the error is not random, it appears more or less always
> in the same two or three places.

What happens if, after the build aborts because of the error, you cd
into /tmp/SBo/qt5... and manually type the make (or is it cmake? or ...?)
command?  Will it start to compile the same source file and crash at
the same place?

Incidentally, I don't recall anyone bringing up the issue of the
possibility that your CPU is overheating.  Is that a possibility?  Can
you monitor the temps as you compile, from another terminal, with
something like

touch temp-log
while true
    date >> temp-log
    sensors >> temp-log
    echo >> temp-log

and see if anything ever gets too hot?

I think you said it compiled under ubuntu.  Perhaps ubuntu is using a
different CPU power profile.



More information about the SlackBuilds-users mailing list