[Slackbuilds-users] BUG: pdftk decrypt doesn't work

Greg' Ar Tourter artourter at gmail.com
Wed Dec 21 10:28:32 UTC 2016

unfortunately, pdftk cannot be compiled using openjdk or oracle java
jdk as far as I know and requires gcj.

I usually have a machine on current but not at the moment so I cannot
test on current.


On 20 December 2016 at 23:50, B Watson <yalhcru at gmail.com> wrote:
>> Error: Unexpected Exception in open_reader()
>> Unhandled Java Exception in main():
>> java.lang.NullPointerException
>>    at gnu.gcj.runtime.NameFinder.lookup(libgcj.so.16)
>>    at java.lang.Throwable.getStackTrace(libgcj.so.16)
>>    at java.lang.Throwable.stackTraceString(libgcj.so.16)
>>    at java.lang.Throwable.printStackTrace(libgcj.so.16)
>>    at java.lang.Throwable.printStackTrace(libgcj.so.16)
> I ran across a similar situation with java code that uses crypto. When
> built with gcj, crypto wasn't supported. When built with openjdk or
> oracle jdk, it worked fine.
> Worth trying, at least.
> _______________________________________________
> SlackBuilds-users mailing list
> SlackBuilds-users at slackbuilds.org
> http://lists.slackbuilds.org/mailman/listinfo/slackbuilds-users
> Archives - https://lists.slackbuilds.org/pipermail/slackbuilds-users/
> FAQ - https://slackbuilds.org/faq/

More information about the SlackBuilds-users mailing list