[Slackbuilds-users] Next Round of Testing - mythtv

Robby Workman rworkman at slackbuilds.org
Mon Feb 8 00:38:32 UTC 2016

On Mon, 8 Feb 2016 10:25:38 +1000
Christoph Willing <chris.willing at iinet.net.au> wrote:

> On 07/02/16 22:59, Christoph Willing wrote:
> > On 07/02/16 18:22, Willy Sudiarto Raharjo wrote:
> >  
> >>
> >> here are the remaining entries of the BUILD FAIL from last week
> >>  
> > ...  
> >>    multimedia/mythtv  
> >
> > I just tried a quick build using the latest source code from
> > https://codeload.github.com/MythTV/mythtv/tar.gz/fixes/0.27
> > (this is 0.27.6 apparently). It builds to completion if the
> > --enable-libvpx option is removed from the configure command.
> >
> > I don't use mythtv myself so I can't really say if this is a
> > reasonable omission to enable the build, although I see it is not
> > enabled by default.  
> There is also an explicit 0.27.6 version at the mythtv github repo:
>      https://github.com/MythTV/mythtv/releases/tag/v0.27.6
> however it produced the same result (builds only if --enable-libvpx
> is removed) even though its just 6 days old.
> There is much better news about building from master which I cloned
> and made a tarball available at:
> http://sourceforge.net/projects/slackbuildsdirectlinks/files/mythtv/mythtv-0git20160208.tar.gz
> (that is not really my place to put tarballs, so I'll will remove if 
> anyone thinks its inappropriate).
> After the minor mods to the SlackBuild needed for the new tarball, 
> building from this git tarball just works using the existing
> configure options but with the added hard requirement of qt5.

Looking at that git repo, it appears to work with libvpx in -current
due to bumping the included ffmpeg, so I'm pretty sure that it needs
(at least) the patch for ffmpeg and ffmpeg010 in the SBo tree already.
It might not (i.e. probably won't) apply flawlessly, so you will need
to rework it a bit, but that should almost surely fix the build failure
with libvpx.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 181 bytes
Desc: OpenPGP digital signature
URL: <http://lists.slackbuilds.org/pipermail/slackbuilds-users/attachments/20160207/bb61b491/attachment.asc>

More information about the SlackBuilds-users mailing list