[Slackbuilds-users] Lilypond ignores the switch for not building dependencies.

Black Rider softwareworks at use.startmail.com
Tue Jan 5 21:45:06 UTC 2016

El Sun, 03 Jan 2016 18:06:30 -0600, Kyle Guinn escribió:

> On 1/3/16, Black Rider <softwareworks at use.startmail.com> wrote:
>> El Sat, 02 Jan 2016 22:04:13 -0600, Kyle Guinn escribió:
>>> On 1/2/16, Black Rider <softwareworks at use.startmail.com> wrote:
>>>> Hello.
>>>> I have noticed that the lilypond SlackBuild requires dblatex in order
>>>> to be properly built. The SlackBuild documentation says that dblatex
>>>> is only required if you are trying to build the documentation, which
>>>> is switched off by default. However, I lilypond seems to be ignoring
>>>> the --enable- documentation=XX switch and requiring the user to
>>>> install the components required for installing the documentation
>>>> anyway.
>>> What error message do you get?
>>> Do you have a full Slackware installation, in particular with tetex
>>> installed?  I get this if it's not installed.  Note that dblatex and
>>> texi2html are optional, they're in the WARNING line, not the ERROR
>>> line.
>>> WARNING: Please consider installing optional programs or files:
>>> texi2html dblatex bibtex pdflatex pdfetex pdftex etex epsf.tex lh CTAN
>>> package (texlive-lang-cyrillic or texlive-texmf-fonts)
>>> ERROR: Please install required programs:  mf-nowin mf mfw mfont mpost
>>> kpsewhich metapost CTAN package (texlive-metapost)
>>> Also, make sure you're using `su -`, not just `su`.  If you just
>>> installed tetex, you'll need to log out and log back in for the PATH
>>> settings to take effect.  See http://slackbuilds.org/howto/#su
>>> -Kyle
>> I found the problem in a fully installed Slackware.
>> I get that same WARNING plus ERROR. Then the script refuses to build
>> up.
>> The program stopped refusing to build after I replaced the stock tetex
>> with texlive and installed dblatex.
> I just built it with texlive/dblatex.  No problems here.  Can you
> pastebin your /tmp/SBo/lilypond-2.18.2/config.log file?
> _______________________________________________
> SlackBuilds-users mailing list SlackBuilds-users at slackbuilds.org
> http://lists.slackbuilds.org/mailman/listinfo/slackbuilds-users Archives
> - http://lists.slackbuilds.org/pipermail/slackbuilds-users/
> FAQ - http://slackbuilds.org/faq/

Building with texlive/dblatex does work (I didn't say otherwise). My 
problem comes when I don't have them.

I don't have the computer I did the building in at hand (it is not mine). 
I remember I tried:

- To modify the script so it had --enable-documentation=no (instead of 
parsing a variable for achieving the same result).
- To run ./configure by hand in the source code with the flag above.

In every occasion, it complained because it lacked dependencies - which I 
tracked to be documentation building tools. Installing texlive/dblatex 
solved the problem.

>>> Also, make sure you're using `su -`, not just `su`.

Maybe that points to the problem, but I would have to check it out.

More information about the SlackBuilds-users mailing list