[Slackbuilds-users] hercules build problem

Don Stalkowski dstalk at execulink.com
Wed Jan 27 13:21:36 UTC 2016


I'm using Slackware-64 14.1 and built hercules using the file
hercules.tar.gz from slackbuilds.

When I tried running it I got "HHCCF042E Device type nnnn not recognized"
errors. A web search yielded results that did not seem applicable
so I downloaded a pre-built version from Niels Horn's site
(<http://www.nielshorn.net/slackware/>). Niels was the hercules
slackbuilds maintainer. This pre-built version worked ok.

The difference between my build and the pre-built version appears
to be that the pre-built version has both ".so" and ".la" files in
the "/usr/lib64/hercules" directory. Mine only has ".la" files.

That makes sense since the "HHCCF042E" errors are likely caused by
missing libraries.

I tried building using the hercules.SlackBuild that came with
the pre-built version and did not get the ".so" files.
I got the same result using a plain configure/make build.

Any ideas about what I'm doing wrong?


More information about the SlackBuilds-users mailing list