[Slackbuilds-users] Problem building truecrypt

Thomas Szteliga ts at websafe.pl
Sun Jun 5 04:25:21 UTC 2016

On 06/05/2016 05:11 AM, Willy Sudiarto Raharjo wrote:
> Tested on lates current and it worked fine
> truecrypt:
>   MD5SUM check for truecrypt-7.1a.tar.gz ... OK
>   Building package truecrypt-7.1a-x86_64-1_SBo.tgz ... OK
>   Installing package truecrypt-7.1a-x86_64-1_SBo.tgz ... OK
> From your error message, it seems that you have wxGTK3 instead of
> wxPython as requested

I'm on 14.1 and:

# ls -1 /var/log/packages/wx*

I'll removepkg wxGTK3 and try again...

OK, after removing of wxGTK3-3.0.2 I'm getting another error:

Compiling CoreUnix.cpp
Compiling CoreLinux.cpp
Updating library Core.a
make[1]: wx-config: Command not found
make[1]: wx-config: Command not found
Precompiling SystemPrecompiled.h
SystemPrecompiled.h:9:19: fatal error: wx/wx.h: No such file or directory
 #include <wx/wx.h>
compilation terminated.
make[1]: *** [SystemPrecompiled.h.gch] Error 1
make: *** [all] Error 2

And finally I solved this problem by doing:

slpkg -s sbo wxGTK

after that I had:

# ls -1 /var/log/packages/wx*

and I was able to build truecrypt :-)

I'm not sure why I had wxGTK3 but I'll probably see it
in a few days ;-)

Thomas Szteliga

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 3719 bytes
Desc: S/MIME Cryptographic Signature
URL: <http://lists.slackbuilds.org/pipermail/slackbuilds-users/attachments/20160605/036db3d1/attachment.p7s>

More information about the SlackBuilds-users mailing list