[Slackbuilds-users] fmodapi access upstream

B Watson yalhcru at gmail.com
Fri Sep 9 23:15:01 UTC 2016

On 9/7/16, Doogster <thedoogster at gmail.com> wrote:
> IIRC, the segfaults happened with regular DOOM. A reliable way to trigger
> them was to set the sound backend to FMOD and FMOD's backend to Pulseaudio,
> restart the sound system (that's a menu option), then start a game.

Unable to reproduce, with gzdoom 2.1.1 and fmodapi 4.28.17, playing either
Doom or Doom II on Slackware64 14.2. The only thing that happens when
I set the sound system to to fmod and the fmod backend to pulseaudio,
then hit 'restart sound', is that gzdoom's log output says this:

FMOD Sound System, copyright © Firelight Technologies Pty, Ltd., 1994-2009.
Loaded FMOD version 4.28.17
No working sound devices found. Try a different snd_output?
FMod Ex Sound init failed. Trying OpenAL.
I_InitSound: Initializing OpenAL

...and in the menu, the sound system option changed itself to OpenAL.

The pulseaudio daemon was running and working (I could e.g. play audio
though it with mplayer or pacat). gzdoom didn't segfault.

Switching gzdoom's fmod backend back to alsa and using fmod as the sound
system, worked fine (gzdoom played normally, audio worked, no segfaults).

Anyone else want to try this out, other than me and Doogster?

More information about the SlackBuilds-users mailing list