[Slackbuilds-users] ffmpeg

Duncan Roe duncan_roe at acslink.net.au
Tue Apr 18 01:42:12 UTC 2017

On Mon, Apr 17, 2017 at 08:23:47PM +0200, Chris Abela wrote:
> 1. On my machines, ffmpeg built against the previous version (à la
> wireshark). Removing it before building it again solved missing libraries
> issues.
> 2. On my second run, ffmpeg complained on missing chromaprint, despite that
> I had it. Disabling it solved this problem
> 3. On third time, I got lucky :-).
> Chris
I hit this yesterday. chromaprint has ffmpeg as an optional dependency, and vice
versa. So, circular dependency. Eventually this worked for me:

 - Build and install ffmpeg without chromaprint (no CHROMAPRINT=yes in the build
line) (VERSION=1a so upgradepkg will install it)
 - Build and install chromaprint
 - Rebuild and install ffmpeg, adding CHROMAPRINT=yes

Maybe I could have built chromaprint twice instead of ffmpeg, but it's done now.

Cheers ... Duncan.

More information about the SlackBuilds-users mailing list