[Slackbuilds-users] [ANN] New SBo Template Tool

Jeremy Hansen jebrhansen+SBo at gmail.com
Tue Apr 18 13:11:49 UTC 2017

On Fri, Apr 14, 2017 at 10:31 PM, Daniel Prosser <dpross1100 at msn.com> wrote:

> I haven't tried it myself, but this also sounds similar to
> sbo-templates:
> https://github.com/dslackw/sbo-templates
> Which is also on SlackBuilds.org. Not sure if you've seen that.

I actually wasn't aware of that. I didn't think to actually look for other
projects providing this. But I think I do prefer a single shell script to
handle it rather than a python script (mainly because I don't know python
very well. But thanks for the info.

On Mon, Apr 17, 2017 at 11:46 PM, Daniel Prosser <dpross1100 at msn.com> wrote:

> I just gave it a quick try. It seems like a useful script when preparing
> a new submission. My test used the cmake template. Here are a few issues
> I noticed:
> 1. I specified a single requirement using the -r option, but it was
> absent from the .info file generated. I tried with and without quotes
> around the requirement.
> The next two are some inconsistencies between the generated SlackBuild
> script and the template from SlackBuilds.org:
> 2. Compress manpages command. The template on SBo has this:
> for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz
> $i.gz ; rm $i ; done
> In the generated script:
> for i in $( find /usr/man -type l ) ; do ln -s $( readlink  ).gz $i.gz ;
> rm $i ; done
> From a quick glance at that line, it looks like your script is not
> handling variables inside other variables. Possibly need to use an
> escape before a $ somewhere.
> 3. The perllocal.pod removal command doesn't have the "|| true" at the
> end like the SBo template.

1. Looks like I used $REQUIRE in one instance and $REQUIRES in the other.

2. Oops, I missed an escape in there for the $PKG variable. I'm going to go
through and see if I missed any others (I did). Hopefully I got them all
this time.

3. This looks to be due to differences in the SBo templates. Both the cmake
and perl templates include the "|| true"  at the end of that find, but the
autotools doesn't (autotools also has that find span multiple lines instead
of the one liner version on the cmake and perl templates. I used the
autotools as the base template for that section. I'll add the "|| true" at
the end and make it a single line to match the cmake and perl templates.

find $PKG -name perllocal.pod \ -o -name ".packlist" \ -o -name "*.bs" \ |
xargs rm -f

find $PKG -name perllocal.pod -o -name ".packlist" -o -name "*.bs" | xargs
rm -f || true

Thanks for the report! And for trying it out. These issues should all be
fixed now.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.slackbuilds.org/pipermail/slackbuilds-users/attachments/20170418/3c0bdaa8/attachment.html>

More information about the SlackBuilds-users mailing list