[Slackbuilds-users] openjdk was: Re: Updates - 20170225.1

Christoph Willing chris.willing at iinet.net.au
Sat Feb 25 23:25:21 UTC 2017

On 25/02/17 18:12, B Watson wrote:
> On 2/24/17, Christoph Willing <chris.willing at iinet.net.au> wrote:
>> Over time, I've had many suggestions and reminders that LibreOffice will
>> build successfully without the jdk package. I prefer a build with as
>> full functionality as is made possible upstream, so I prefer that it
>> remain as a requirement. Java haters are welcome to add --without-java
>> or --with-java=no to their local versions - which reminds me I could add
>> a JAVA=no option to the SlackBuild at the next version update.
> Will it work with openjdk rather than Oracle's jdk?
> That's probably a question that should be asked about any of the builds
> mentioned in this thread.
> If the answer is "it requires a JDK, and will work with either jdk or
> openjdk", what's the best way to handle that? List jdk in REQUIRES,
> and say "you can use openjdk instead of jdk" in the README? Or, list
> neither in REQUIRES, and in the README say "you need one of either jdk
> or openjdk"?
> Or, maybe openjdk should be listed in REQUIRES, as it's easier to deal
> with (doesn't require jumping through hoops to download like jdk does)?
> In which case the README would say "you can use jdk instead of openjdk"?

I haven't tried openjdk for a long time - there were often problems
running it with the java apps I was using at that time and the Oracle
version always just worked. However that was some time ago and your
comment about being 'easier to deal with' (in automated build systems,
at least) is a good point.

Therefore I tried building openjdk in a fresh 14.2 64bit VM and very
soon had the following failure:

    [javac] Compiling 2760 source files to
    [javac] Annotation processing got disabled, since it requires a 1.6
compliant JVM
    [javac] java.lang.NullPointerException
    [javac]    at
    [javac]    at
    [javac]    at
    [javac]    at
    [javac]    at
    [javac]    at
    [javac]    at

/tmp/SBo/openjdk/icedtea-build/openjdk-boot/jaxws/build.xml:155: Compile
failed; see the compiler error output for details.

Total time: 1 second
Makefile:150: recipe for target 'all' failed

This morning I've just started a build in a 32bit VM which is not
complete yet but seems to be progressing just fine. Is there a known
problem with openjdk on 64bit? Does anyone recognize the failure above
and/or know a possible solution?


More information about the SlackBuilds-users mailing list