[Slackbuilds-users] wine-2.0 and wine-2.0.1 no longer compile: missing gnutls_hash

King Beowulf kingbeowulf at gmail.com
Sat May 13 17:32:27 UTC 2017

On 05/13/2017 07:32 AM, David Woodfall wrote:
>> On 05/08/2017 09:54 PM, Willy Sudiarto Raharjo wrote:
>>>> I tried upgrading to wine-2.0.1 and got during configure:
>>>> -------------
>>>> checking gnutls/gnutls.h usability... yes
>>>> checking gnutls/gnutls.h presence... yes
>>>> checking for gnutls/gnutls.h... yes
>>>> checking for -lgnutls... not found
>>>> checking for gnutls_hash... no
>>>> configure: error: libgnutls 32-bit development files not found, no
>>>> schannel support.
>>>> This is an error since --with-gnutls was requested.
>>>> ---------------
>>>> Oddly, I'm running wine-2.0.  Trying to rec-ompile wine-2.0  also now
>>>> fails with the same error.  wine-2.0 compiled fine on 01-FEB-2017 (the
>>>> package I am currently using).  All the updates to Slackware64 14.2 and
>>>> multilib are installed as of 08-MAY-2017.
>>>> I'll try later with a clean VM, but does anyone have any ideas?
>>> have you tried to reinstall gnutls just in case it was overwritten?
>> yes, first thing.  AH....it's not gnutls that is missing but a gnutls
>> dependency:
>> libunistring-compat32-0.9.3-x86_64-1compat32
>> where did that come from and why was it missing?  weird.  slackpkg or I
>> missed it.
>> well, let see what happens...
>> -Ed
> Hi. Did you sort this out?
> -Dave

Yes, it turns out I was missing libunistring-compat32 which it seems
gnutls-compat32 now needs for wine to compile after digging through the
configure logs.  slackpkg+ showed that libunistring-compat32 was
available but not installed from my mirror of Alienbob's multilib tree.
I am not sure which version of gnutls I used in my initial compile on
01-FEB-2017 (there was a gnutls patch posted on 12-JAN-2017), and
libunistring seems to have been added to compat32 on 01-MAR-2017.

Again, this glitch only effected slack64 multilib, which SBo does not
support ;-) and slack32 was fine.

I tested compiles of both wine-2.0.1 and wine-2.7 (staging) after
installing libunistring-compat32 and all is good.  I an running wine-2.7


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 181 bytes
Desc: OpenPGP digital signature
URL: <http://lists.slackbuilds.org/pipermail/slackbuilds-users/attachments/20170513/8d5fe688/attachment.asc>

More information about the SlackBuilds-users mailing list