[Slackbuilds-users] Spamassassin from SBo - broken DNS RBL filtering?

Sebastian Arcus s.arcus at open-t.co.uk
Wed May 17 14:18:03 UTC 2017

I have been chasing this issue on-and-off for months, and spent a lot of 
time the last few days on it. I run several Slackware servers with 
Spamassassin on them, and I  noticed a while ago that some don't use DNS 
blocklists. This is a very subtle problem, because SpamAssassin is not 
showing any errors anywhere, either with debug turned on or using 
--lint. Also, the Pyzor, bayes and other filters are so good, that most 
email gets filtered correctly anyway - so I didn't realise for a good 
while that the dns blocklists weren't being used. Only by running the 
same known spam message containing spammy links through SpamAssassin on 
both servers I realised that one of them was not using dns rbl's

I am running SA 3.4.1 everywhere on Slackware -current and a Slackware 
14.2 (both 32 and 64 bit) - none of these make a difference. I have even 
removed all Perl modules (and Perl) and re-installed the latest versions 
directly from CPAN. I tried resetting all the SpamAssassin configs to 
defaults, and removed all the SA rules and re-run sa-update.

The only thing that has cured it eventually, at the suggestion of 
someone on the SpamAssassin mailing list, is manually compiling and 
installing SpamAssassin 3.4.1 downloaded directly from apache.org. This 
would suggest that the SBo scripts somehow break the dns rbl's 
functionality for SpamAssassin - but I'm afraid I have been unable to 
determine how.

I'm putting this outthere in case it helps someone - or if somebody has 
some idea as to how we can narrow this further. Also maybe others who 
have SpamAssassin installed on their system might want to run the above 
check and provide some input, it would be really useful.

More information about the SlackBuilds-users mailing list