[Slackbuilds-users] webkit2gtk build problems

Jason Graham jgraha8 at gmail.com
Mon Sep 18 15:02:48 UTC 2017

On Mon, Sep 18, 2017 at 10:56 AM, Ythogtha <yth at ythogtha.org> wrote:

> > > I got the same error as Habs on a stable install.
> >
> > I was convinced by Matteo and David that webkit2gtk build fine on stable
> > and current for both arch, BUT it requires a LOT of resources, so i
> > cancelled my revert and update README instead to make additional SWAP
> > space if you have small amount of memory installed.
>         After the package is created, the temporary build directory takes
> 1.1Gb.
> It's not that big, but it is also true that the build takes up a lot of
> resources during compilation.
>         My computer only has 8Gb of RAM. Maybe using multiple jobs may be a
> problem, I use -j2, and my computer is on its knees (or chips, or circuits,
> don't know... ^^) when building, but it builds fine.

I had a similar experience. I first tried with -j8 on a VM and the
compilation finished (or at least the cmake progress showed 100%) but it
didn't proceed from there. There were 4Gb of ram allocated to this VM so I
suppose it was resource constrained based on other folks' findings. It
stalled for quite some time (~30min) before I killed the job.

So I tried again with -j1 and it failed in the same location has Habs.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.slackbuilds.org/pipermail/slackbuilds-users/attachments/20170918/26f491c7/attachment-0001.html>

More information about the SlackBuilds-users mailing list