[Slackbuilds-users] qt-creator fails (?) to build with qt-creator-llvm

Jheengut Pritvi z.coldplayer at gmail.com
Fri Dec 14 15:13:15 UTC 2018

On Tue, 15 May 2018 at 17:25, Andrzej Telszewski <atelszewski at gmail.com>

> On 11/05/18 02:27, B Watson wrote:
> > On 5/10/18, Andrzej Telszewski <atelszewski at gmail.com> wrote:
> >>
> >> Because it builds fine on my side, I run out of ideas what might be
> >> wrong on his side.
> >
> > You and your user both using the same version of Slackware, the same arch
> > (32-bit or 64-bit)? With or without multilib, if you're both on 64-bit?
> He confirms that our setups are mostly the same.
> Anyway, I asked him to post to the ML.
> Thanks.
> --
> Best regards / Pozdrawiam,
> Andrzej Telszewski
> _______________________________________________
> SlackBuilds-users mailing list
> SlackBuilds-users at slackbuilds.org
> https://lists.slackbuilds.org/mailman/listinfo/slackbuilds-users
> Archives - https://lists.slackbuilds.org/pipermail/slackbuilds-users/
> FAQ - https://slackbuilds.org/faq/

I am also having some issues but I need to confirm if this is the case to
continue in this thread since I am not using qt-creator-llvm.
I could not compile qt-creator-llvm initially, I will try again and post in
the future.

*cd clangbackend/ && ( test -e Makefile || /usr/bin/qmake-qt5 -o Makefile
<http://clangbackend.pro> 'QMAKE_CXXFLAGS=-O2 -fPIC' QTC_PREFIX=/usr
WARNING: Clang LibTooling is disabled because only version 5.0 is
supported.make[3]: Entering directory
'/tmp/sbopkg.yH3Sdt/qt-creator-4.6.2/src/tools/clangbackend'g++ -c -O2
-fPIC -Wno-noexcept-type -O2 -O2 -fPIC -std=gnu++1y -Wall -W -D_REENTRANT
-DQT_CORE_LIB -I../../../src -I../../../src -I../../libs
-I/tmp/sbopkg.yH3Sdt/qt-creator-4.6.2/tools -I../../plugins -I../../libs
-I../../libs/sqlite -I../../libs/clangsupport -Isource -isystem
/usr/include -isystem /usr/include/qt5 -isystem
/usr/include/qt5/QtConcurrent -isystem /usr/include/qt5/QtWidgets -isystem
/usr/include/qt5/QtGui -isystem /usr/include/qt5/QtNetwork -isystem
/usr/include/qt5/QtCore -I.moc/release-shared -isystem /usr/include/libdrm
-I/usr/lib64/qt5/mkspecs/linux-g++ -o
source/clangcodecompleteresults.cppIn file included from
/usr/include/c++/8.2.0/bits/stl_algo.h:59,                 from
/usr/include/c++/8.2.0/algorithm:62,                 from
/usr/include/qt5/QtCore/qglobal.h:142,                 from
/usr/include/qt5/QtCore/QtGlobal:1,                 from
../../libs/sqlite/sqliteglobal.h:30,                 from
../../libs/sqlite/utf8string.h:28,                 from
source/clangcodecompleteresults.h:30,                 from
fatal error: stdlib.h: No such file or directory #include_next
<stdlib.h>               ^~~~~~~~~~compilation terminated.make[3]: ***
[Makefile:785: .obj/release-shared/clangcodecompleteresults.o] Error
1make[3]: Leaving directory
'/tmp/sbopkg.yH3Sdt/qt-creator-4.6.2/src/tools/clangbackend'make[2]: ***
[Makefile:229: sub-clangbackend-make_first] Error 2make[2]: Leaving
directory '/tmp/sbopkg.yH3Sdt/qt-creator-4.6.2/src/tools'make[1]: ***
[Makefile:179: sub-tools-make_first-ordered] Error 2make[1]: Leaving
directory '/tmp/sbopkg.yH3Sdt/qt-creator-4.6.2/src'make: *** [Makefile:46:
sub-src-make_first-ordered] Error 2*

Especially ::

/usr/include/c++/8.2.0/cstdlib:75:15: fatal error: stdlib.h: No such file
or directory

I have been reading some forums and it seems this issue started when there
was a change in
gcc version bump as from 6.0.  Could you please confirm or  I will make a
new thread.

I am using Slackware-current and sbopkg. Three times I compiled and got the
same error.

Cheers Pritvi
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.slackbuilds.org/pipermail/slackbuilds-users/attachments/20181214/804b4aae/attachment-0001.html>

More information about the SlackBuilds-users mailing list