[Slackbuilds-users] Sage build still broken?

JCA 1.41421 at gmail.com
Sun Feb 25 20:39:51 UTC 2018

The Sage website offers a number of binaries for Linux that can be
installed under Slackware without any problems. With a bit of care, they
can be installed anywhere, and be made available to anyone. At least, as
far as I can tell - I can't discard the possibility of Sage complaining
once you start making a heavy use of it.

The point is, why is a Sage package being kept in Slackbuilds, if it is
known to lead to a nonworking installation? It's worse than not having it
there at all - were it not part of the Slackbuilds packages, one would at
least waste no time running the Slackbuilds build and install script,
which, as anybody who has tried can attest, takes a good many hours and
lots of disk space. If, because the Sage packaging/development team are a
bunch of dicks, a Slackbuilds package can't be properly built, shouldn't
the latter be removed, until such time that the issue is fixed?

In the meantime, one could use an approach based on the Linux binaries
mentioned above; I believe that is solution #1 as proposed. No patching
seems to be necessary though - just unpack it in the directory where it is
supposed to be installed, run it once as root, in order for it to set the
environment correctly, change ownership/permissions of the unpacked tree,
as necessary, and create a relevant soft link to /usr/bin. With this, it
does not seem terribly difficult to end up with a working Slackware package
for Sage, and a similar approach is already taken in Slackbuilds for other
software, like LibreOffice or Chromium. I agree that it is preferable to
able to build it for your target system, but only if things work properly
in the end.

On Sun, Feb 25, 2018 at 12:02 PM, Didier Spaier <didier at slint.fr> wrote:

> Hello,
> Le 25/02/2018 à 17:44, JCA a écrit :
> <snip>
> >    When trying to use it, this is what I am getting:
> >
> > $ sage
> > ************************************************************************
> > It seems that you are attempting to run Sage from an unpacked source
> > tarball, but you have not compiled it yet (or maybe the build has not
> > finished). You should run `make` in the Sage root directory first.
> > If you did not intend to build Sage from source, you should download
> > a binary tarball instead. Read README.txt for more information.
> > ************************************************************************
> >
> >    This in a freshly installed 14.2 system, with 24G RAM and 1TB disk
> space. The compilation was completed normally, ending up with 13GB worth of
> files in /tmp/SBo, and more than 5GB in /opt/sage.
> >
> >    What have I done wrong? If nothing, is there any point in keeping
> Sage in Slackbuilds? Even in a beefy system, compiling Sage takes a several
> hours - and ending up with lots of GBs eaten up in your hard drive and a
> nonfunctional application is frustrating.
> >
> As it happens I have compiled (but not pacakaged) sage-8.1 15 days ago,
> just to check for a bind friend where the pdf were stored when e.g. drawing
> a sphere.
> I just unpacked  a git archive then ran:
> tar xf sage-8.1.tar.gz
> cd sage-8.1
> ./configure | tee /tmp/config.LOG
> time make 2>/tmp/sageERR |tee /tmp/sageLOG
> I attach config.LOG but not sageLOG, too heavy (25M), but here is hw it
> ends:
> >Testing that Sage starts...
> >[2018-02-06 23:26:22] SageMath version 8.1, Release Date: 2017-12-07
> >This looks like the first time you are running Sage.
> >Cleaning up, do not interrupt this.
> >Done cleaning.
> >Yes, Sage starts.
> >make[2] : on quitte le répertoire « /tmp/sage-8.1/build/make »
> >make[1] : on quitte le répertoire « /tmp/sage-8.1/build/make »
> >
> >real   257m49.177s
> >user   262m42.133s
> >sys    11m29.261s
> >Sage build/upgrade complete!
> >
> >To install small scripts to directly run Sage's versions of GAP,
> >the PARI/GP interpreter, Maxima, or Singular etc. (by typing e.g.
> >just 'gap' or 'gp') into a standard 'bin' directory, start Sage
> >by typing 'sage' (or './sage') and enter something like
> >
> >    install_scripts('/usr/local/bin')
> >
> >at the Sage command prompt ('sage:').
> My laptop didn't burn this time...
> didier[/tmp]$ du -sh sage-8.1/
> 7,7G    sage-8.1/
> It worked here, that's all I know.
> Didier
> _______________________________________________
> SlackBuilds-users mailing list
> SlackBuilds-users at slackbuilds.org
> https://lists.slackbuilds.org/mailman/listinfo/slackbuilds-users
> Archives - https://lists.slackbuilds.org/pipermail/slackbuilds-users/
> FAQ - https://slackbuilds.org/faq/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.slackbuilds.org/pipermail/slackbuilds-users/attachments/20180225/50fde861/attachment-0001.html>

More information about the SlackBuilds-users mailing list