[Slackbuilds-users] qt5 is sorely in need of an update

orbea at fredslev.dk orbea at fredslev.dk
Sat Jul 7 05:04:41 UTC 2018

> Sorry, I forgot to upload the qt5 5.9.2 SlackBuild and .info. Done.

I went to test before you noticed this and found your Qt-5.10.1 script
instead. After many cryptic build failures I was informed that gentoo
never unmasked 5.10 and now considers 5.11 to be stable. So I tried
your script to build 5.11 and it worked on the first try with just
changing the version number.

I next updated your python2-sip to 4.19.11 as required by PyQt5-5.11.2.

I wasn't able to quickly figure out how to make PyQt5 happy with a
private sip so I applied the attached debian patch to build with a
public sip, but there might be a better way to do that for someone with
more patience to figure it out.

Lastly I found that they broke INSTALL_ROOT and again, I didn't dwell
on it long and worked around it with this sed before make since it
seemed to be not that important...

sed -i '/mk_distinfo.py/d' Makefile

Other than that, everything on my system that requires Qt5 builds and
seems to work fine with the exception of solarus-quest-editor which
suffers build errors with the newer Qt5. However their git master is
fixed and I seem to have backported the fix successfully. I plan to
apply it to the SlackBuild if further testing doesn't reveal more

The single program I have that uses PyQt5, m64py, the lackluster gui
front end to the standalone version of mupen64plus also seems to work as
well as it did before. However I build this with my own script based on
the git master since the stable versions are hopelessly outdated.

Lastly my rpcs3 (PS3 emulator) script which I also build from their git
master hasn't worked for a long time since they started requiring at
least Qt 5.10. With the newer version it now builds again.

I tested this on current and will try again with 14.2 tomorrow, but
personally I would prefer 5.11 over 5.9 and would suggest skipping 5.10.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: public_sip.diff
Type: text/x-patch
Size: 1886 bytes
Desc: not available
URL: <http://lists.slackbuilds.org/pipermail/slackbuilds-users/attachments/20180706/dd724342/attachment.bin>

More information about the SlackBuilds-users mailing list