[Slackbuilds-users] build of zathura stops on CURRENT

Matteo Bernardini matteo.bernardini at gmail.com
Mon Jul 23 13:25:38 UTC 2018

2018-07-23 13:12 GMT+02:00 Matteo Bernardini <matteo.bernardini at gmail.com>:
> 2018-07-23 12:29 GMT+02:00 Franzen <slackbuilds at schoepfer.info>:
>>> In file included from zathura/synctex.c:8:0:
>>> /usr/include/synctex/synctex_parser.h:53:29: fatal error:
>>> synctex_version.h: No such file or directory
>>> compilation terminated.
>> Attached patch adds synctex_version.h to texlive,
>> and may be applied to the buildscript by
>> + # Add missing synctex header
>> + patch -Np0 -i $CWD/patches/synctex-missing-header.patch || exit 1
> Hi Johannes,
> I applied the patch to texlive and then tried again to rebuild zathura
> and qpdfview, but unfortunately it seems that synctex still doesn't
> work :(
> https://pastebin.com/yTvC4ErA
> https://pastebin.com/NxBrMAPC

actually, if I upgrade qpdfview to the latest beta release it seems to
build fine if I apply the above patch to texlive.

but, as its README says, zathura cannot be upgraded in stable because
the last version compatible with gtk+3 in stable is 0.3.8, so an
eventual update that fixes the build with the newer synctex might be

-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001-office-qpdfview-Updated-for-version-0.4.17beta1.patch
Type: text/x-patch
Size: 6018 bytes
Desc: not available
URL: <http://lists.slackbuilds.org/pipermail/slackbuilds-users/attachments/20180723/01415471/attachment-0001.bin>

More information about the SlackBuilds-users mailing list