[Slackbuilds-users] vlc slackbuild

David Melik dchmelik at gmail.com
Sun Feb 24 00:38:37 UTC 2019

On 2/23/19 4:06 PM, Tim Dickson via SlackBuilds-users wrote:
> On 23/02/2019 03:17, Christoph Willing wrote:
>> On 23/2/19 3:51 am, Tim Dickson via SlackBuilds-users wrote:
>>> On 22/02/2019 12:51, Christoph Willing wrote:
>>>> On 22/2/19 8:33 pm, Tim Dickson via SlackBuilds-users wrote:
>>>>> vlc was built with the options OPENCV=yes WAYLAND=yes
>>>>> I can provide all the build options chosen for all the deps if it 
>>>>> would
>>>>> help.
>>>> I admit that I don't test that particular option combination very 
>>>> often.
>>>> I just rebuilt vlc with OPENCV=yes (using opencv-legacy) and a quick
>>>> test of the resulting vlc was fine.
>>>> However the wayland option is quite time consuming to test since it
>>>> requires qt5 to have been (re)built with wayland, wayland-egl &
>>>> wayland-protocols already installed. It's now late enough here that it
>>>> will be an overnight job to rebuild qt5 and then vlc.
>>>> In the meantime, could you build & test vlc without wayland support?
>>>> Success there would indicate that wayland support is the problem. Then
>>>> we'd have to figure out a possible fix or just not support that option
>>>> any more.
>>>> chris
>>> I've now also tried the other way around, enable wayland and disable
>>> opencv (legacy) and it now runs without seg-faulting, which is the
>>> opposite result of your test!. I'm open to more suggestions, 
>>> although at
>>> least it runs now,
>> I finished building wayland enabled (but otherwise standard) qt5 and vlc
>> in a stock 14.2 x86_64 VM with opencv-legacy. It runs normally - no
>> segfault and I can play a test video with it.
>> When run it from a terminal, the only new output is:
>>      libEGL warning: DRI2: failed to authenticate
>> but it has no apparent effect to the running vlc.
>> Since you're segfault-free after removing opencv-legacy, I guess that's
>> the place to look for a cause - perhaps some exotic option it's built 
>> with?
> (looking at opencv-legacy, I built it will all options, including 
> ffmpeg which is a recursive dependency via frie0r)
>> chris
> Although without opencv , vlc starts up ok, when I try to play an mp4 
> video file i get
> codec not supported
> VLC could not decode the format "h264" (H264 -MPEG-4 AVC (part 10))
> despite the fact that vlc and ffmpeg have been compiled with everything
> (all required and optional dependencies) except libva and 
> libva-intel-driver
> (as I use amd apu's.)
> any ideas?

I think I already commented/replied at least once in recent weeks/months 
that vlc hasn't worked for me for over a year.  I get similar errors 
trying to play any sort of video, and it won't compile anymore either.  
I know with some SlackBuilds (such as GNUtella) the flags, that SBo 
administrators have decided should be in every build (fpic, etc.) break 
the SlackBuild.  What about trying it without some of these so-called 
'required'/default flags?  I don't have much hope for vlc because 
actually it's also totally broken when I try to play any video on some 
other GNU/Linux OS distributions that may have official packages...

More information about the SlackBuilds-users mailing list