[Slackbuilds-users] appstream-glib build error

phalange at komputermatrix.com phalange at komputermatrix.com
Sat Dec 10 22:55:28 UTC 2022

Hi folks, I'm getting this error building appstream-glib 0.8.2 -- tried 
it on two devices with vanilla installs of Slack15 and got the same 
error. Any suggestions?

The Meson build system
Version: 0.59.4
Source dir: /tmp/SBo/appstream-glib-appstream_glib_0_8_2
Build dir: /tmp/SBo/appstream-glib-appstream_glib_0_8_2/build
Build type: native build
Project name: appstream-glib
Project version: 0.8.2
C compiler for the host machine: ccache cc (gcc 11.2.0 "cc (GCC) 
C linker for the host machine: cc ld.bfd 2.37-slack15
Host machine cpu family: x86_64
Host machine cpu: x86_64
Found pkg-config: /usr/bin/pkg-config (0.29.2)
Run-time dependency gio-2.0 found: YES 2.70.3
Run-time dependency gmodule-2.0 found: YES 2.70.3
Run-time dependency gio-unix-2.0 found: YES 2.70.3
Run-time dependency uuid found: YES 2.37.4
Found CMake: /usr/bin/cmake (3.21.4)
Run-time dependency libarchive found: NO (tried cmake)

../meson.build:76:0: ERROR: Could not generate cargs for libarchive:
Package iconv was not found in the pkg-config search path.
Perhaps you should add the directory containing `iconv.pc'
to the PKG_CONFIG_PATH environment variable
Package 'iconv', required by 'libarchive', not found

More information about the SlackBuilds-users mailing list