<div dir="ltr"><div dir="ltr"><br></div><br><div class="gmail_quote"><div dir="ltr" class="gmail_attr">On Sat, Apr 20, 2019 at 10:51 AM mickski 56 <<a href="mailto:mickski56@hotmail.com">mickski56@hotmail.com</a>> wrote:<br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">valgrind fails to build against openmpi-4<br>
<br>
error: 'MPI_UB' undeclared (first use in this function)<br>
<br>
Solution: rebuild openmpi with "--enable-mpi1-compatibility"<br>
added to the slackbuild. support for this will go away in a future<br>
release of openmpi though.<br>
<br>
Upstream are aware. See <a href="https://bugs.kde.org/show_bug.cgi?id=401416" rel="noreferrer" target="_blank">https://bugs.kde.org/show_bug.cgi?id=401416</a><br>
</blockquote><div><br></div><div>Thanks for the warning, I've just submitted an updated openmpi version with the --enable-mpi1-compatibility flag activated. <br></div><div><br></div><div>Best regards.<br></div><div><br></div><div>¬†</div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">_______________________________________________<br>
SlackBuilds-users mailing list<br>
<a href="mailto:SlackBuilds-users@slackbuilds.org" target="_blank">SlackBuilds-users@slackbuilds.org</a><br>
<a href="https://lists.slackbuilds.org/mailman/listinfo/slackbuilds-users" rel="noreferrer" target="_blank">https://lists.slackbuilds.org/mailman/listinfo/slackbuilds-users</a><br>
Archives - <a href="https://lists.slackbuilds.org/pipermail/slackbuilds-users/" rel="noreferrer" target="_blank">https://lists.slackbuilds.org/pipermail/slackbuilds-users/</a><br>
FAQ - <a href="https://slackbuilds.org/faq/" rel="noreferrer" target="_blank">https://slackbuilds.org/faq/</a><br>
<br>
</blockquote></div><br clear="all"><br>-- <br><div dir="ltr" class="gmail_signature">*****************<br>¬† ¬†Emmanuel</div></div>