[Slackbuilds-users] I failed to build qt5

M Wedin wedinm at gmail.com
Wed May 6 15:30:35 UTC 2020

2020-05-06 17:00 GMT+02:00, Dave Woodfall <dave at slackbuilds.org>:
> On 2020-05-06 14:27,
> M Wedin <wedinm at gmail.com> put forth the proposition:
>> > Have you changed the SlackBuild in any way? I saw a similar problem
>> > recently while experimenting with the use of additional "system"
>> > libraries (as opposed to using third party code included in the source
>> > tarball).
>> No. I haven't changed a single thing. I tried at first to update it
>> with sboupgrade. But that failed instantly. So I downloaded the tar.gz
>> from slackbuilds.org and the source for qt5 via slackbuilds.org.
>> That's it. I ran ./qt5.SlackBuild without any options.
>> > One thing that stands out is:
>> >> -isystem../../../../../../../usr/lib64/dbus-1.0/include -std=gnu++14
>> >
>> > I don't think that standard is supported in the stock g++ supplied with
>> > 14.2 is it?
>> That's beyond me.
>> Wedin
> That was addressed to me.
> What does `which ninja' output?

This is from a different machine, but with the same set of software. I
surmise the one at home would show exactly the same result.

root at rick:~# which ninja
root at rick:~#


More information about the SlackBuilds-users mailing list