[Slackbuilds-users] sboinstall chromprint fails

Ed Fletcher ed at fletcher.ca
Thu Jun 22 21:53:30 UTC 2023

While using sbo to put vlc on a freshly installed and updated 
Slackware64-15.0 (sboinstall vlc), the process failed on chromaprint.  I 
tried chromaprint by itself (sboinstall chromaprint) but it failed with 
the same error:

In file included from 
                  from /tmp/SBo/chromaprint-1.5.1/src/cmd/fpcalc.cpp:7:
/usr/include/libavcodec/avcodec.h:3047:5: note: declared here
  3047 | int avcodec_decode_audio4(AVCodecContext *avctx, AVFrame *frame,
       |     ^~~~~~~~~~~~~~~~~~~~~
make[2]: *** [src/cmd/CMakeFiles/fpcalc.dir/build.make:76: 
src/cmd/CMakeFiles/fpcalc.dir/fpcalc.cpp.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:244: 
src/cmd/CMakeFiles/fpcalc.dir/all] Error 2
make: *** [Makefile:136: all] Error 2
   chromaprint: chromaprint.SlackBuild return non-zero

What I find strange is that downloading the source and the slackbuild 
let me install it successfully.  This let sboinstall finish installing 
vlc.  So I have everything working, just left with a puzzle.

Ed Fletcher

"When I became a man I put away childish things, including the fear of 
childishness and the desire to be very grown up.”
― C.S. Lewis

More information about the SlackBuilds-users mailing list