[Slackbuilds-users] Openoffice.org 2.0.4

Eric Hameleers e.hameleers at chello.nl
Wed Nov 8 14:15:39 UTC 2006

teo teo wrote:
> Hi all,
> I tried to install Openoffice.org 2.0.4, but i got "rpm2cpio not found".
> For those who don't want to install that utility (for many reasons), use
> the perl version by Roger Espel Llima available at
> http://www.iagora.com/~espel/rpm2cpio
> I simply saved rpm2cpio to /usr/bin and I replaced "rpm2cpio" with "perl
> /usr/bin/rpm2cpio" in openoffice.org.SlackBuild ; everything worked
> fine, without need of thousands of "utilities" like rpm.....
> Why not to edit the official openoffice.org.SlackBuild script file this
> way ?

The Slackware "rpm" package contains "rpm2tgz" which allows easy
conversion from RPM to Slackware package format. This in turn uses the
rpm2cpio program.
If you don't want rpm on your box, then that is your business. For all
those other people who occasionally need the rpm-related tools,
Slackware has them ready in the default full install.
Your proposal would require people to go hunting for yet another 3rd
party script which is not part of Slackware, which is not a good thing
Get over it, install the rpm package. You're not forced to use rpm to
*install* your packages are you?


Eric Hameleers
Email: alien at slackware.com
Jabber: alien at jabber.xs4all.nl
Gpg fingerprint: F2CE 1B92 EE1F 2C0C E97E  581E 5E56 AAAF A75C BDA0

More information about the Slackbuilds-users mailing list