[Slackbuilds-users] sbopkg 0.0.5 released

Bob Lounsbury boblounsbury at gmail.com
Sun Apr 6 15:25:21 EDT 2008

On Sun, Apr 6, 2008 at 12:53 PM, Chess Griffin <chess at chessgriffin.com> wrote:
> Bob Lounsbury wrote:
> > I just installed sbopkg on Slackintosh 12.0. Everything seemed to go
> > fine and work until I tried to 'create and edit a local slackbuild'.
> > Selecting this option takes me to the slackbuild in what looks like
> > nano, but strange things are happening. When I try to type my computer
> > beeps at me then if I keep pushing a key it allows me to type. If I
> > create a line I can't delete it.
> >
> > The most important thing though is that I don't see any way to exit
> > and save my changes. Normally under nano this is a simple ctrl->x, but
> > the normal nano menu is not visible. I tried esc, but there is just no
> > way to escape and save changes and then build the package with these
> > changes. Any suggestions?
> >
> > Cheers,
> > /Bob
> >
>  sbopkg uses whatever you have set the environmental variable $EDITOR to,
> and will fall back to 'vi' if $EDITOR has not been set.  So, to test, I set
> root's EDITOR to nano also and it seemed to work fine.  I could edit
> SlackBuilds and the little menu at the bottom was there.
>  Are you doing this as root or regular user?

As a regular user. Should it be done as root?

> What is the output of 'echo $EDITOR' for the user running sbopkg?

Strange. I just get a blank line. Nothing is listed. I guess that's
the problem. So, how do I set the system/user editor?

>  I have not tested this on Slackintosh, but I don't see how that could
> affect things.
>  Thanks-
>  Chess


More information about the Slackbuilds-users mailing list