[Slackbuilds-users] lyx_qt4 slackbuild fails during make

Robby Workman rworkman at slackbuilds.org
Sat Jan 26 02:01:16 UTC 2008

Bob Lounsbury wrote:

> For some strange reason I wanted to try Archlinux so I installed that
> and tried it out using their kdemod package. All I have to say is: "No
> thank you". After I had installed a few programs and what not, I
> looked at top and X was using over 30% of my CPU and some ksplash item
> was using another 30% of my CPU so everything was reacting slowly on
> the computer. So, I said no thank you, and reinstalled Slackware. I've
> only been using Slackware for a few weeks, so I'm a total noob, but I
> love Slackware. I haven't experienced the smoothness of Slackware in
> any other distro.

You're ruined now.  :)

> On to my point of writing this email. After I reinstalled Slackware
> (for the 3rd time now actually), qt4 installed without any problems.
> Then lyx_qt4 gave some error, so I issued 'ldconfig' and restarted to
> be safe, ran lyx again and it also installed without any problems. So,
> I have no idea what so ever why qt4 wouldn't build before, but it's
> working now. Just thought I'd give an update.

That's great to hear.  Well, it's *mostly* great to hear.  I still
haven't been able to reliably reproduce it - as it turns out, the
other guy who had this happen to him also managed to make the build
complete.  We're still not sure exactly why or how :/

Interestingly enough, I got an ICE (internal compiler error) when
building qt4 a couple of nights ago on my dev box, but due to some
BIOS/hardware/RAM/donthaveaclue problems also present, I didn't
think anything of it.  It's a new box, and I just updated the BIOS
in it and all seems fine so far, but once I'm sure it's ready to go,
I'll give qt4 another run and see what happens.

Regardless, I still have no clue what really caused all that, and
I suspect that it would be very difficult to debug.  Here's hoping
it doesn't show up again :)


More information about the Slackbuilds-users mailing list