[Slackbuilds-users] qtoctave SlackBuild doesn't work

lanceb at ksu.edu lanceb at ksu.edu
Sat May 10 17:20:19 UTC 2008

First of all, I want to thank you for the good work you are doing. The
last week has been my first real use of Slackware. Now that I
understand it, I wish I had tried it earlier, it's popular because it's
good. SlackBuilds.org is a big part of what makes it great.

I tried to build qtoctave (0.7.1) using the existing SlackBuild. While
that does successfully build the package, there is unfortunately a bug
that will prevent it from running:


The current version of qtoctave is 0.7.4. The problem is that
significant changes were made in the qtoctave source package between
0.7.1 and 0.7.4, such that the SlackBuild for 0.7.1 will quit with
errors due to missing files if you try to run it with 0.7.4.

After some searching and trial and error, I got it to build. I took the
existing SlackBuild, updated the version to 0.7.4, then commented out
the following lines

./configure \
--prefix=/usr \

This version of qtoctave is compiled using cmake. My qt4 came from
slacky.eu, so I had to tell it where to find my qt4 installation.
Following this forum post:


I replaced the above commented lines with

cmake -DQT_QMAKE_EXECUTABLE=/opt/qt4/bin/qmake .
make install INSTALL_ROOT=$PKG

The SlackBuild still did not work. I had to comment out the following
lines at the bottom because the files do not exist in qtoctave 0.7.4:

cp -a $PRGNAM/doc LEEME.txt NEWS.txt LICENSE_GPL.txt README.txt \
ln -s /usr/share/$PRGNAM/qtoctave-doc
cp $CWD/octave-sombrero.png $PKG/usr/share/qtoctave/images

It then built and ran properly.

More information about the Slackbuilds-users mailing list